win32cpp: win32cpp::Application Class Reference

  • Main Page
  • Namespaces
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
win32cpp::Application

win32cpp::Application Class Reference

Application is a singleton that provides basic information about the current process. More...

#include <Application.hpp>

List of all members.

Public Member Functions

const uistring & | CommandLine () const
Returns the command line specified in WinMain.
TopLevelWindow * MainWindow ()
Returns a pointer to the main Window.
operator HINSTANCE () const
Returns the Application instance's HINSTANCE.
HINSTANCE | PreviousInstance () const
Returns the "previous" HINSTANCE specified in WinMain.
void | Run (TopLevelWindow &mainWindow)
Show the specified TopLevelWindow and runs the message pump.
int | ShowCommand () const
Returns the "show command" specified in WinMain.
SysTray * | SysTrayManager () const
Returns the systray manager.
void | Terminate () const
Terminates the application if it is running.
ApplicationThread * Thread ()
Returns the ApplicationThread associated with this application instance.

Static Public Member Functions

static void | Initialize (HINSTANCE instance, HINSTANCE previousInstance, LPTSTR commandLine, int showCommand)
Initialize the Application instance.
static Application & | Instance ()
Returns the Application instance.

Classes

class | ApplicationAlreadyInitializedException
Thrown if Application::Initialize() is called more than once. More...
class | ApplicationAlreadyRunningException
Thrown if Application::Run() is called while the application is already running. More...

Detailed Description

Application is a singleton that provides basic information about the current process.

Application::Initialize should be called from the WinMain method, followed by Application::Run to show the main Window and start the message loop.

Access Application's sole instance by using the Application::Instance method.

See also:
TopLevelWindow

Member Function Documentation

void Application::Initialize | ( | HINSTANCE | instance,
 |  | HINSTANCE | previousInstance,
 |  | LPTSTR | commandLine,
 |  | int | showCommand |
 | ) |  |  | [static]

Initialize the Application instance.

This method is best called from WinMain.

Parameters:
instance | The HINSTANCE supplied to WinMain.
previousInstance | The "previous" HINSTANCE supplied to WinMain.
commandLine | The command line supplied to WinMain
showCommand | The show command supplied to WinMain.
Exceptions:
AlreadyInitializedException This exception is thrown if Initialize() has already been called
See also:
Application::Run

Application & Application::Instance ( ) [static]

Returns the Application instance.

Returns:
The Application instance.

TopLevelWindow * Application::MainWindow ( )

Returns a pointer to the main Window.

If this value is NULL the application is not currently running.

void Application::Run ( TopLevelWindow & mainWindow )

Show the specified TopLevelWindow and runs the message pump.

Parameters:
mainWindow The Application's main Window.
Exceptions:
AlreadyRunningException AlreadyRunningException will be thrown if the Application instance is already runnning.

Generated on Wed Sep 3 17:44:07 2008 for win32cpp by doxygen 1.5.6


win32cpp: Member List

  • Class List
  • Class Hierarchy
  • Class Members

win32cpp::Application Member List

This is the complete list of members for win32cpp::Application, including all inherited members.

CommandLine() const | win32cpp::Application |
Initialize(HINSTANCE instance, HINSTANCE previousInstance, LPTSTR commandLine, int showCommand) | win32cpp::Application | [static]
Instance() | win32cpp::Application | [static]
MainWindow() | win32cpp::Application |
operator HINSTANCE() const | win32cpp::Application |
PreviousInstance() const | win32cpp::Application |
Run(TopLevelWindow &mainWindow) | win32cpp::Application |
ShowCommand() const | win32cpp::Application |
SysTrayManager() const | win32cpp::Application |
Terminate() const | win32cpp::Application |
Thread() | win32cpp::Application |


win32cpp: win32cpp::Application::ApplicationAlreadyInitializedException Class Reference

win32cpp::Application::ApplicationAlreadyInitializedException

win32cpp::Application::ApplicationAlreadyInitializedException Class Reference

Thrown if Application::Initialize() is called more than once. More...

#include <Application.hpp>

Inheritance diagram for win32cpp::Application::ApplicationAlreadyInitializedException:

[legend]

List of all members.

Detailed Description

Thrown if Application::Initialize() is called more than once.


win32cpp: Member List

win32cpp::Application::ApplicationAlreadyInitializedException Member List

This is the complete list of members for win32cpp::Application::ApplicationAlreadyInitializedException, including all inherited members.

Exception() | win32cpp::Exception |
Exception(const char *message) | win32cpp::Exception |
Message() | win32cpp::Exception | [virtual]


win32cpp: win32cpp::Application::ApplicationAlreadyRunningException Class Reference

win32cpp::Application::ApplicationAlreadyRunningException

win32cpp::Application::ApplicationAlreadyRunningException Class Reference

Thrown if Application::Run() is called while the application is already running. More...

#include <Application.hpp>

Inheritance diagram for win32cpp::Application::ApplicationAlreadyRunningException:

[legend]

List of all members.

Detailed Description

Thrown if Application::Run() is called while the application is already running.


win32cpp: Member List

win32cpp::Application::ApplicationAlreadyRunningException Member List

This is the complete list of members for win32cpp::Application::ApplicationAlreadyRunningException, including all inherited members.

Exception() | win32cpp::Exception |
Exception(const char *message) | win32cpp::Exception |
Message() | win32cpp::Exception | [virtual]


win32cpp: win32cpp::ApplicationThread Class Reference

win32cpp::ApplicationThread

win32cpp::ApplicationThread Class Reference

ApplicationThread is a class handling intercommunication to main thread. More...

#include <ApplicationThread.hpp>

List of all members.

Public Member Functions

ApplicationThread ()
Constructor.
~ApplicationThread ()
Destructor.

Static Public Member Functions

static bool InMainThread ()
Ask if the current caller is executed in the main thread.

Detailed Description

ApplicationThread is a class handling intercommunication to main thread.

To make a call to the main thread you do like this:

   win32cpp::ApplicationThread::Call1(this /*pointer to object*/,&MyClass::MyMethod,argument1);

The calls are using the sigslot library and are threadsafe. If the object is deleted before mainthread have the time to call it, the call will not be made.

Remarks:
ApplicationThread has only one instance in the Application class (singleton)
See also:
Application

Constructor & Destructor Documentation

ApplicationThread::~ApplicationThread ( )

Destructor.

Remarks:
Will also delete the HelperWindow


win32cpp: Member List

win32cpp::ApplicationThread Member List

This is the complete list of members for win32cpp::ApplicationThread, including all inherited members.

ApplicationThread() | win32cpp::ApplicationThread |
InMainThread() | win32cpp::ApplicationThread | [static]
~ApplicationThread() | win32cpp::ApplicationThread |


win32cpp: win32cpp::BarLayout Class Reference

win32cpp::BarLayout

win32cpp::BarLayout Class Reference

TODO: document me. More...

#include <BarLayout.hpp>

Inheritance diagram for win32cpp::BarLayout:

[legend]

List of all members.

Public Member Functions

BarLayout (BarLayoutOrientation orientation=BarRowLayout)
Constructor.
void | SetSpacing (int spacing)
Sets the amount spacing between children, in pixels.
int | Spacing () const
Returns the amount of spacing between children (in pixels).

Detailed Description

TODO: document me.

Constructor & Destructor Documentation

BarLayout::BarLayout ( BarLayoutOrientation orientation = BarRowLayout )

Constructor.

Parameters:
orientation A win32cpp::BarLayoutOrientation.

Member Function Documentation

void BarLayout::SetSpacing ( int spacing )

Sets the amount spacing between children, in pixels.

Parameters:
spacing The amount of spacing, in pixels.


win32cpp: Member List

win32cpp::BarLayout Member List

This is the complete list of members for win32cpp::BarLayout, including all inherited members.

AddChild(WindowType *window) | win32cpp::Container | [inline]
BackgroundColor() const | win32cpp::Window |
BarLayout(BarLayoutOrientation orientation=BarRowLayout) | win32cpp::BarLayout |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Panel() | win32cpp::Panel |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
RemoveChild(WindowType *window) | win32cpp::Container | [inline]
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetSpacing(int spacing) | win32cpp::BarLayout |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
Spacing() const | win32cpp::BarLayout |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::Button Class Reference

win32cpp::Button

win32cpp::Button Class Reference

A standard push-button. The Button::Pressed event is emitted when the user activates the button. More...

#include <Button.hpp>

Inheritance diagram for win32cpp::Button:

[legend]

List of all members.

Public Member Functions

Button (const uichar *caption=_T(""))
Constructor.

Public Attributes

ButtonPressedEvent Pressed
This event is emitted when the user presses the Button.

Detailed Description

A standard push-button. The Button::Pressed event is emitted when the user activates the button.

Constructor & Destructor Documentation

Button::Button ( const uichar * caption = _T("") )

Constructor.

Parameters:
caption The caption that will be drawn on the button.


win32cpp: Member List

win32cpp::Button Member List

This is the complete list of members for win32cpp::Button, including all inherited members.

BackgroundColor() const | win32cpp::Window |
Button(const uichar *caption=_T("")) | win32cpp::Button |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Pressed | win32cpp::Button |
Redraw() const | win32cpp::Window |
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::Checkbox Class Reference

win32cpp::Checkbox

win32cpp::Checkbox Class Reference

A standard Checkbox. More...

#include <Checkbox.hpp>

Inheritance diagram for win32cpp::Checkbox:

[legend]

List of all members.

Public Member Functions

Checkbox (const uichar *caption=_T(""), int style=BS_AUTOCHECKBOX)
Constructor.

Public Attributes

CheckboxPressedEvent Pressed
This event is emitted when the user presses the Checkbox.

Detailed Description

A standard Checkbox.

Constructor & Destructor Documentation

Checkbox::Checkbox | ( | const uichar * | caption = _T(""),
 |  | int | style = BS_AUTOCHECKBOX
 | ) |  |

Constructor.

Parameters:
caption The caption that beside the checkbox


win32cpp: Member List

win32cpp::Checkbox Member List

This is the complete list of members for win32cpp::Checkbox, including all inherited members.

BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
Checkbox(const uichar *caption=_T(""), int style=BS_AUTOCHECKBOX) | win32cpp::Checkbox |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Pressed | win32cpp::Checkbox |
Redraw() const | win32cpp::Window |
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::Color Struct Reference

win32cpp::Color

win32cpp::Color Struct Reference

An RGBA color. This class can be implicitly casted to and from Win32 COLORREF objects. More...

#include <Color.hpp>

List of all members.

Public Member Functions

Color (COLORREF color)
Constructor.
Color (byte red=255, byte green=255, byte blue=255, byte alpha=0)
Constructor.
virtual | operator COLORREF ()
Returns a Win32 COLORREF based on the Color.

Static Public Member Functions

static Color | Darken (const Color &color, byte amount)
Darkens a Color by the specified amount.
static Color | Lighten (const Color &color, byte amount)
Lightens a Color by the specified amount.
static Color | SystemColor (DWORD systemColorID)
Returns a Color based on a system color identifier.

Detailed Description

An RGBA color. This class can be implicitly casted to and from Win32 COLORREF objects.

   COLORREF baseColor = RGB(255, 0, 0);
   Color myColor = baseColor;
   Color::Lighten(myColor, 15);
   COLORREF newColor = myColor;

Constructor & Destructor Documentation

win32cpp::Color::Color | ( | byte | red = 255,
 |  | byte | green = 255,
 |  | byte | blue = 255,
 |  | byte | alpha = 0
 | ) |  |

Constructor.

Parameters:
red | The red component of the color.
green | The green component of the color.
blue | The blue component of the color.
alpha | The alpha component of the color.

win32cpp::Color::Color ( COLORREF color )

Constructor.

Parameters:
color A COLORREF used to create this color

Member Function Documentation

Color win32cpp::Color::Darken | ( | const Color & | color,
 |  | byte | amount |
 | ) |  |  | [static]

Darkens a Color by the specified amount.

Parameters:
color | The color to darken.
amount | The amount to darken.
Returns:
A new Color, "amount" darker than the input color.
See also:
Color::Lighten

Color win32cpp::Color::Lighten | ( | const Color & | color,
 |  | byte | amount |
 | ) |  |  | [static]

Lightens a Color by the specified amount.

Parameters:
color | The color to lighten.
amount | The amount to lighten.
Returns:
A new Color, "amount" lighter than the input color.
See also:
Color::Darken

Color win32cpp::Color::SystemColor ( DWORD systemColorID ) [static]

Returns a Color based on a system color identifier.

For example:

   Color myColor = Color::SystemColor(COLOR_BTNFACE);

Parameters:
systemColorID A system color identifier.
Returns:
A Color based on the specified system color identifier.


win32cpp: Member List

win32cpp::Color Member List

This is the complete list of members for win32cpp::Color, including all inherited members.

Color(byte red=255, byte green=255, byte blue=255, byte alpha=0) | win32cpp::Color |
Color(COLORREF color) | win32cpp::Color |
Darken(const Color &color, byte amount) | win32cpp::Color | [static]
Lighten(const Color &color, byte amount) | win32cpp::Color | [static]
operator COLORREF() | win32cpp::Color | [virtual]
SystemColor(DWORD systemColorID) | win32cpp::Color | [static]


win32cpp: win32cpp::Container Class Reference

win32cpp::Container

win32cpp::Container Class Reference

Container is a specialization of Window that can house one or more child controls. More...

#include <Container.hpp>

Inheritance diagram for win32cpp::Container:

[legend]

List of all members.

Public Member Functions

template<typename WindowType>
WindowType * | AddChild (WindowType *window)
Add the specified Window as a child of the Container.
template<typename WindowType>
WindowType * | RemoveChild (WindowType *window)
Removes the specified Window from the Container.

Detailed Description

Container is a specialization of Window that can house one or more child controls.

Use Container::AddChild and Container::RemoveChild to manage children. Once a Window is added to a Container, the Container takes ownership of it. Do not, under any circumstances, call delete on a Window that is a child of a Container! If the caller removes a child via Container::RemoveChild he is then responsible for deleting it.

A Window may only have one parent, and a WindowAlreadyHasParentException will be thrown if this contract is violated.

Some types of Containers can only hold a specific number of children, and will throw a TooManyChildWindowsException if that number is exceeded. Frame, for example, only allows one child Window. Splitter allows two. Be sure to read the documentation of classes derived from Container for more information.

Member Function Documentation

template<typename WindowType>
WindowType * win32cpp::Container::AddChild ( WindowType * window ) [inline]

Add the specified Window as a child of the Container.

This method is a templated to make adding children as painless as possible. The return value is a pointer to the child that was just added. The user can use this method as follows:

   Label* myLabel = myContainer->AddChild(new Label(_T("Value: ")));

Parameters:
window The Window to add.
Returns:
Returns the Window that was added.
Exceptions:
WindowIsNullException | if window is NULL
WindowAlreadyHasParentException | if the Window already has a parent
WindowAlreadyHasParentException | if a class derived from Container doesn't like the child
See also:
Container::RemoveChild

template<typename WindowType>
WindowType * win32cpp::Container::RemoveChild ( WindowType * window ) [inline]

Removes the specified Window from the Container.

Whoever calls this method is responsible for deleting the Window returned. This method is templated to make this as painless as possible. The return value is a pointer to the window removed.

   delete myContainer->RemoveChild(myLabel);

Parameters:
window The Window to remove.
Returns:
Returns the Window that was removed.
Exceptions:
WindowIsNullException | if window is NULL
WindowHasNoParentException | if the Window doesn't have a parent
InvalidChildWindowException | if a class derived from Container doesn't like the child
See also:
Container::AddChild


win32cpp: Member List

win32cpp::Container Member List

This is the complete list of members for win32cpp::Container, including all inherited members.

AddChild(WindowType *window) | win32cpp::Container | [inline]
BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
RemoveChild(WindowType *window) | win32cpp::Container | [inline]
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::EditView Class Reference

win32cpp::EditView

win32cpp::EditView Class Reference

A standard edit control. More...

#include <EditView.hpp>

Inheritance diagram for win32cpp::EditView:

[legend]

List of all members.

Public Member Functions

EditView (int width, int height)
Constructor.
void | LimitText (int chars)
LimitText Sets the limit for the amount of text that can be entered.
void | SelectAll ()
SelectAll Selects all the characters in the view.
void | SetReadOnly (bool setting)
SetReadOnly Sets the edit control to be read only.
void | SetSelection (int first, int second)
SetSelection Sets the positions of the first and last character of selected text in the edit box.
void | SetTooltip (uistring text)
SetTooltip Sets the tooltip text for the edit control.
void | ShowCaret ()
ShowCaret Moves the caret to a visible position.
void | Undo ()
Undo Undoes the last edit.

Detailed Description

A standard edit control.

Constructor & Destructor Documentation

EditView::EditView | ( | int | width,
 |  | int | height
 | ) |  |

Constructor.

Parameters:
width | The width of the edit box
height | The height of the edit box

Member Function Documentation

void EditView::LimitText ( int chars )

LimitText Sets the limit for the amount of text that can be entered.

Parameters:
chars The number of characters allowed

void EditView::SetReadOnly ( bool setting )

SetReadOnly Sets the edit control to be read only.

Parameters:
setting True or False (Read only and Read/Write respectively)

void EditView::SetSelection | ( | int | first,
 |  | int | second
 | ) |  |

SetSelection Sets the positions of the first and last character of selected text in the edit box.

Parameters:
first | The position of the first char to select
second | The position of the end char to select up to

void EditView::SetTooltip ( uistring text )

SetTooltip Sets the tooltip text for the edit control.

Parameters:
text The tooltip text to set


win32cpp: Member List

win32cpp::EditView Member List

This is the complete list of members for win32cpp::EditView, including all inherited members.

BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
EditView(int width, int height) | win32cpp::EditView |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
LimitText(int chars) | win32cpp::EditView |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SelectAll() | win32cpp::EditView |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetReadOnly(bool setting) | win32cpp::EditView |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetSelection(int first, int second) | win32cpp::EditView |
SetTabStop(bool enabled) | win32cpp::Window |
SetTooltip(uistring text) | win32cpp::EditView |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
ShowCaret() | win32cpp::EditView |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
Undo() | win32cpp::EditView |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::Exception Class Reference

win32cpp::Exception

win32cpp::Exception Class Reference

The base class for all exceptions thrown by win32cpp. More...

#include <Exception.hpp>

Inheritance diagram for win32cpp::Exception:

[legend]

List of all members.

Public Member Functions

Exception (const char *message)
Constructor.
Exception ()
Default constructor.
virtual const char * Message ()
Returns a string representation of the exception, usually a description.

Detailed Description

The base class for all exceptions thrown by win32cpp.


win32cpp: Member List

win32cpp::Exception Member List

This is the complete list of members for win32cpp::Exception, including all inherited members.

Exception() | win32cpp::Exception |
Exception(const char *message) | win32cpp::Exception |
Message() | win32cpp::Exception | [virtual]


win32cpp: win32cpp::Font Struct Reference

win32cpp::Font

win32cpp::Font Struct Reference

Font provides a light-weight wrapper around a Win32 HFONT object. More...

#include <Font.hpp>

List of all members.

Public Member Functions

bool | Bold () const
void | DrawToHDC (HDC hdc, const Rect &rect, const uistring &caption, TextAlignment=TextAlignLeft)
Renders text to the specified device context.
uistring | FaceName () const
HFONT | GetHFONT ()
Return the HFONT representation of the Font object. Do NOT call DeleteObject() on the HFONT returned.
bool | Italic () const
Returns the Font's italic property.
unsigned | PointSize () const
Returns the point size of the font.
void | SetBold (bool bold=true)
Sets the Font's bold property.
void | SetFaceName (const uistring &faceName)
Sets the Font's facename.
void | SetItalic (bool italic=true)
Sets the Font's weight.
void | SetPointSize (unsigned pointSize)
Sets the Font's point size.
void | SetUnderline (bool underline=true)
Sets the Font's underline property.
void | SetWeight (int weight)
Sets the Font's weight.
bool | Underline () const
Returns the Font's underline property.
int | Weight () const

Static Public Member Functions

static HFONT | CreateHFONT (const Font &font, HDC hdc)
Create a HFONT from a Font object. The caller is responsible for calling DeleteObject() on the HFONT when finished with it.

Detailed Description

Font provides a light-weight wrapper around a Win32 HFONT object.

Font exposes many useful utility functions for manipulating the underlying font attributes, including: face, size, weight, italic, and underline.

See also:
FontRef

Member Function Documentation

bool Font::Bold ( ) const

Returns:
true if the Font is bold.

HFONT Font::CreateHFONT | ( | const Font & | font,
 |  | HDC | hdc |
 | ) |  |  | [static]

Create a HFONT from a Font object. The caller is responsible for calling DeleteObject() on the HFONT when finished with it.

Parameters:
font | the Font to use when creating the HFONT
hdc | the device context to use when creating the font. If this parameter is NULL the desktop DC will be used.
Returns:
a new HFONT. Caller is responsible for calling DeleteObject()

void Font::DrawToHDC | ( | HDC | hdc,
 |  | const Rect & | rect,
 |  | const uistring & | caption,
 |  | TextAlignment | alignment = TextAlignLeft
 | ) |  |

Renders text to the specified device context.

Parameters:
hdc | the device context to render the text to.
rect | the bounding rectangle.
caption | the text to render.
alignment | the text alignment to use

uistring Font::FaceName ( ) const

Returns:
the Font's faceName.

HFONT Font::GetHFONT ( )

Return the HFONT representation of the Font object. Do NOT call DeleteObject() on the HFONT returned.

Returns:
a HFONT representation of the Font.

void Font::SetFaceName ( const uistring & faceName )

Sets the Font's facename.

Parameters:
faceName the font's facename.

void Font::SetItalic ( bool italic = true )

Sets the Font's weight.

See: http://msdn2.microsoft.com/en-us/library/ms534214.aspx

void Font::SetWeight ( int weight )

Sets the Font's weight.

See: http://msdn2.microsoft.com/en-us/library/ms534214.aspx

int Font::Weight ( ) const

Returns:
Returns the Font's weight.
See: http://msdn2.microsoft.com/en-us/library/ms534214.aspx


win32cpp: Member List

win32cpp::Font Member List

This is the complete list of members for win32cpp::Font, including all inherited members.

Bold() const | win32cpp::Font |
CreateHFONT(const Font &font, HDC hdc) | win32cpp::Font | [static]
DrawToHDC(HDC hdc, const Rect &rect, const uistring &caption, TextAlignment=TextAlignLeft) | win32cpp::Font |
FaceName() const | win32cpp::Font |
GetHFONT() | win32cpp::Font |
Italic() const | win32cpp::Font |
PointSize() const | win32cpp::Font |
SetBold(bool bold=true) | win32cpp::Font |
SetFaceName(const uistring &faceName) | win32cpp::Font |
SetItalic(bool italic=true) | win32cpp::Font |
SetPointSize(unsigned pointSize) | win32cpp::Font |
SetUnderline(bool underline=true) | win32cpp::Font |
SetWeight(int weight) | win32cpp::Font |
Underline() const | win32cpp::Font |
Weight() const | win32cpp::Font |


win32cpp: win32cpp::Frame Class Reference

win32cpp::Frame

win32cpp::Frame Class Reference

Frame is a Container that adds a padding (border) to a single child Window. More...

#include <Frame.hpp>

Inheritance diagram for win32cpp::Frame:

[legend]

List of all members.

Public Member Functions

Frame (Window *child, const FramePadding &padding)
Constructor.
Frame (Window *child=NULL, int padding=0)
Constructor.
void | SetPadding (int padding)
Set the Child's padding.
void | SetPadding (const FramePadding &padding)
Set the Child's padding.

Detailed Description

Frame is a Container that adds a padding (border) to a single child Window.

If the child is resized, Frame will automatically resize itself to accomidate the child and respect the the specified FramePadding. If the Frame is resized, it will automatically resize the child window to fit its new ClientSize.

Attempting to add more than 1 child Window to a Frame will result in a TooManyChildWindowsException.

See also:
Container, Panel

Constructor & Destructor Documentation

Frame::Frame | ( | Window * | child = NULL,
 |  | int | padding = 0
 | ) |  |

Constructor.

Remarks:
If child is not specified (NULL) it can be added later by using the Container::AddChild method.
Parameters:
child | The Window to be housed within the frame.
padding | The amount of padding, in pixels, for all edges.

Frame::Frame | ( | Window * | child,
 |  | const FramePadding & | padding
 | ) |  |

Constructor.

Remarks:
If child is not specified (NULL) it can be added later by using the Container::AddChild method.
Parameters:
child | The Window to be housed within the frame.
padding | The padding parameters to use.

Member Function Documentation

void Frame::SetPadding ( int padding )

Set the Child's padding.

Parameters:
padding The amount of padding, in pixels, for all edges.

void Frame::SetPadding ( const FramePadding & padding )

Set the Child's padding.

Parameters:
padding The new padding parameters to use.


win32cpp: Member List

win32cpp::Frame Member List

This is the complete list of members for win32cpp::Frame, including all inherited members.

AddChild(WindowType *window) | win32cpp::Container | [inline]
BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
Frame(Window *child=NULL, int padding=0) | win32cpp::Frame |
Frame(Window *child, const FramePadding &padding) | win32cpp::Frame |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Panel() | win32cpp::Panel |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
RemoveChild(WindowType *window) | win32cpp::Container | [inline]
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetPadding(const FramePadding &padding) | win32cpp::Frame |
SetPadding(int padding) | win32cpp::Frame |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::FramePadding Struct Reference

win32cpp::FramePadding

win32cpp::FramePadding Struct Reference

FramePadding is used by Frame to specify the padding around the child control. More...

#include <Frame.hpp>

List of all members.

Public Member Functions

FramePadding (const FramePadding &padding)
Copy constructor.
FramePadding (int left, int right, int top, int bottom)
Constructor.
FramePadding (int padding=0)
Constructor.
bool | operator!= (const FramePadding &padding) const
Inequality operator.
bool | operator== (const FramePadding &padding) const
Equality operator.

Public Attributes

int | bottom
Bottom padding, in pixels.
int | left
Left padding, in pixels.
int | right
Right padding, in pixels.
int | top
Top padding, in pixels.

Detailed Description

FramePadding is used by Frame to specify the padding around the child control.

See also:
Frame.


win32cpp: Member List

win32cpp::FramePadding Member List

This is the complete list of members for win32cpp::FramePadding, including all inherited members.

bottom | win32cpp::FramePadding |
FramePadding(int padding=0) | win32cpp::FramePadding | [inline]
FramePadding(int left, int right, int top, int bottom) | win32cpp::FramePadding | [inline]
FramePadding(const FramePadding &padding) | win32cpp::FramePadding | [inline]
left | win32cpp::FramePadding |
operator!=(const FramePadding &padding) const | win32cpp::FramePadding | [inline]
operator==(const FramePadding &padding) const | win32cpp::FramePadding | [inline]
right | win32cpp::FramePadding |
top | win32cpp::FramePadding |


win32cpp: win32cpp::Label Class Reference

win32cpp::Label

win32cpp::Label Class Reference

A simple Window that draws only a caption. More...

#include <Label.hpp>

Inheritance diagram for win32cpp::Label:

[legend]

List of all members.

Public Member Functions

bool | AutoResizeFromCaptionEnabled () const
Returns whether or not the label will be automatically resized when the caption is changed.
void | EnableAutoResizeFromCaption (bool enable=true)
If enabled the Label will automatically resize itself when the caption is changed.
Label (const uichar *caption=_T(""))
Constructor.
void | ResizeFromCaption ()
Resizes the Label to the size of the caption.

Detailed Description

A simple Window that draws only a caption.

Constructor & Destructor Documentation

Label::Label ( const uichar * caption = _T("") )

Constructor.

Parameters:
caption The caption to draw.

Member Function Documentation

void Label::ResizeFromCaption ( )

Resizes the Label to the size of the caption.

ResizeFromCaption will generate a Resized event.


win32cpp: Member List

win32cpp::Label Member List

This is the complete list of members for win32cpp::Label, including all inherited members.

AutoResizeFromCaptionEnabled() const | win32cpp::Label |
BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
EnableAutoResizeFromCaption(bool enable=true) | win32cpp::Label |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Label(const uichar *caption=_T("")) | win32cpp::Label |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
ResizeFromCaption() | win32cpp::Label |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::LinearLayout Class Reference

win32cpp::LinearLayout

win32cpp::LinearLayout Class Reference

A Container that is used to stack controls horizontally or vertically. More...

#include <LinearLayout.hpp>

Inheritance diagram for win32cpp::LinearLayout:

[legend]

List of all members.

Public Member Functions

LinearLayout (LinearLayoutOrientation orientation=LinearRowLayout)
Constructor.
void | SetChildAlignment (Window *child, ChildAlignment alignment)
Set the alignment of the specified child within the LinearLayout.
void | SetChildFill (Window *child, bool enabled=true)
Sets whether or not the child will be automatically resized in the direction opposite the orientation. See LinearLayout for an example.
void | SetDefaultChildAlignment (ChildAlignment alignment)
Sets the default alignment for child controls.
void | SetDefaultChildFill (bool enabled=true)
Sets whether or not child controls are filled by default.
void | SetFlexibleChild (Window *child)
Set the LinearLayout's flexible child.
void | SetSpacing (int spacing)
Sets the amount spacing between children, in pixels.
int | Spacing () const
Returns the amount of spacing between children (in pixels).

Detailed Description

A Container that is used to stack controls horizontally or vertically.

Children are added to and removed from a LinearLayout using Container::AddChild and Container::RemoveChild, respectively. The order in which the children are arranged is determined by the order in which they are added to the Container. First in, first out.

The orientation (LinearRowLayout or LinearColumnLayout) is determined at construction time by specifying a win32cpp::LinearLayoutOrientation.

If a child is resized, LinearLayout will adjust its internal layout and sze.

    // create a new Horizontal LinearLayout with 4 buttons.
    LinearLayout* layout = new LinearLayout(LinearColumnLayout);
    layout->AddChild(new Button(_T("Prev")));
    layout->AddChild(new Button(_T("Play")));
    layout->AddChild(new Button(_T("Stop")));
    layout->AddChild(new Button(_T("Next")));

Children specified as "filled" may be automatically resized in the direction opposite of the LinearLayout's orientation. Setting a child's "Fill" property can is done via LinearLayout::SetChildFill. Consider the following illustration of a horizontal LinearLayout with 4 children:

   |-----------------------------------------------| <-- Column LinearLayout
   |                                  |-----------||
   ||--------|                        |           ||
   || Child1 ||----------||----------||  Child4   ||
   ||        ||  Child2  ||  Child3  ||           ||
   ||--------||----------||----------||-----------||
   |-----------------------------------------------|

Specifying Child2 as "Filled" will make the layout look as follows:

   |-----------------------------------------------|
   |          |----------|            |-----------||
   ||--------||          |            |           ||
   || Child1 ||  Child2  ||----------||  Child4   ||
   ||        ||          ||  Child3  ||           ||
   ||--------||----------||----------||-----------||
   |-----------------------------------------------|

A LinearLayout can optionally include a single "flexible" child. The flexible child will grow or shrink if the LinearLayout is resized manually by the user. Consider the following example where a LinearLayout that has been resized:

   |------------------------------------------------------------| <-- Column LinearLayout
   ||--------||--------||--------||---------|                   |
   || Child1 || Child2 || Child3 || Child4  |                   |
   ||--------||--------||--------||---------|                   |
   |------------------------------------------------------------|

Setting Child2 as "flexible" will result in the following layout:

   |------------------------------------------------------------|
   ||--------||-------------------------||----------||---------||
   || Child1 || Child2 (flexible)       ||  Child3  || Child4  ||
   ||--------||-------------------------||----------||---------||
   |------------------------------------------------------------|

Child controls can also be aligned in a BoxLayout via LinearLayout::SetChildAlignment and win32cpp::ChildAlignment

   Column LinearLayout alignment styles
   |--------------------|
   |   ChildAlignTop    |
   |                    |
   |  ChildAlignMiddle  |
   |                    |
   |  ChildAlignBottom  |
   |--------------------|

   Row LinearLayout alignment styles
   |---------------------------------------------------------|
   |                                                         |
   | ChildAlignLeft     ChildAlignCenter     ChildAlignRight |
   |                                                         |
   |---------------------------------------------------------|

Constructor & Destructor Documentation

LinearLayout::LinearLayout ( LinearLayoutOrientation orientation = LinearRowLayout )

Constructor.

Parameters:
orientation A win32cpp::LinearLayout.

Member Function Documentation

void LinearLayout::SetChildAlignment | ( | Window * | child,
 |  | ChildAlignment | alignment
 | ) |  |

Set the alignment of the specified child within the LinearLayout.

Parameters:
child | The child to align.
alignment | The new alignment.
Exceptions:
InvalidChildWindowException if child is not a child window
See also:
ChildAlignment

void LinearLayout::SetChildFill | ( | Window * | child,
 |  | bool | enabled = true
 | ) |  |

Sets whether or not the child will be automatically resized in the direction opposite the orientation. See LinearLayout for an example.

Parameters:
child | The child whose property to modify
enabled | Whether or not to enable filling
Exceptions:
Container::InvalidChildWindowException if the specified child is not a child of this LinearLayout.

void LinearLayout::SetDefaultChildAlignment ( ChildAlignment alignment )

Sets the default alignment for child controls.

Parameters:
alignment The new default alignment.
See also:
ChildAlignment

void LinearLayout::SetDefaultChildFill ( bool enabled = true )

Sets whether or not child controls are filled by default.

Parameters:
enabled Whether or not to fill child controls by default
See also:
LinearLayout::SetChildFill

void LinearLayout::SetFlexibleChild ( Window * child )

Set the LinearLayout's flexible child.

The flexible child will grow or shrink when the LinearLayout is resized.

Parameters:
child The child to set as flexible.
Exceptions:
Container::InvalidChildWindowException if the specified child is not a child of this LinearLayout.

void LinearLayout::SetSpacing ( int spacing )

Sets the amount spacing between children, in pixels.

Parameters:
spacing The amount of spacing, in pixels.


win32cpp: Member List

win32cpp::LinearLayout Member List

This is the complete list of members for win32cpp::LinearLayout, including all inherited members.

AddChild(WindowType *window) | win32cpp::Container | [inline]
BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
LinearLayout(LinearLayoutOrientation orientation=LinearRowLayout) | win32cpp::LinearLayout |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Panel() | win32cpp::Panel |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
RemoveChild(WindowType *window) | win32cpp::Container | [inline]
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetChildAlignment(Window *child, ChildAlignment alignment) | win32cpp::LinearLayout |
SetChildFill(Window *child, bool enabled=true) | win32cpp::LinearLayout |
SetDefaultChildAlignment(ChildAlignment alignment) | win32cpp::LinearLayout |
SetDefaultChildFill(bool enabled=true) | win32cpp::LinearLayout |
SetFlexibleChild(Window *child) | win32cpp::LinearLayout |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetSpacing(int spacing) | win32cpp::LinearLayout |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
Spacing() const | win32cpp::LinearLayout |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::ListView Class Reference

win32cpp::ListView

win32cpp::ListView Class Reference

A ListView is used for displaying data in row/column format. More...

#include <ListView.hpp>

Inheritance diagram for win32cpp::ListView:

[legend]

List of all members.

Public Types

typedef boost::shared_ptr
< CellRenderer > 		CellRendererRef
A shared pointer to a ListView::CellRenderer.
typedef sigslot::signal2
< ListView *, ColumnRef > 		ColumnClickedEvent
typedef boost::shared_ptr< Column > | ColumnRef
A shared pointer to a ListView::Column.
typedef sigslot::signal3
< ListView *, int, ColumnRef > 		HotCellChangedEvent
typedef sigslot::signal2
< ListView *, int > 		HotRowChangedEvent
typedef boost::shared_ptr< Model > | ModelRef
A shared pointer to a ListView::Model.
typedef sigslot::signal2
< ListView *, int > 		RowActivatedEvent
typedef std::vector< int > | RowIndexList
typedef boost::shared_ptr
< RowRenderer > 		RowRendererRef
A shared pointer to a ListView::RowRenderer.
typedef sigslot::signal1
< ListView * > 		SelectionChangedEvent

Public Member Functions

void | AddColumn (ColumnRef column)
Adds the specified column to the view.
bool | CellAtPoint (const Point &location, int &rowIndex, ColumnRef &column) const
Returns the row index and column at the specified Point.
bool | ColumnsVisible () const
Returns true if the column headers are visible, false otherwise.
int | ColumnWidth (ColumnRef column) const
Returns the width of the specified column.
void | EnableColumnResizing (bool enable)
Enables column resizing via click and drag.
void | EnableMultipleSelection (bool enable)
Enables multiple row selection.
void | EnableStripedBackground (bool enable)
Enables alternating row background color.
ColumnRef | HotColumn () const
Returns the Column currently under the mouse cursor.
int | HotRow () const
Returns the index of the row currently under the mouse cursor.
ListView ()
Default constructor.
bool | MultipleSelectionEnabled () const
Returns true if multiple row selection is enabled.
void | RedrawCell (int rowIndex, ColumnRef column) const
Redraw the cell at the specified index and Column.
void | RedrawRow (int rowIndex) const
Redraw the row at the specified index.
void | RemoveColumn (ColumnRef column)
Removes the specified column from the view.
bool | ResizableColumnsEnabled () const
Returns true if column resizing is enabled.
int | RowAtPoint (const Point &location) const
Returns the index of the row under the specified Point.
int | RowHeight () const
Returns the height of the rows displayed in the ListView.
void | ScrollToRow (int rowIndex)
Scrolls the ListView to assure the item at rowIndex is visible.
int | SelectedRow ()
Returns the index of the selected row.
RowIndexList SelectedRows ()
Returns a std::vector<int> that contains the selected row indices.
void | SetColumnsVisible (bool visible)
Set the visibility of the column header.
bool | SetColumnWidth (ColumnRef column, int width)
Sets the width of the specified column.
void | SetContextMenu (MenuRef contextMenu)
Sets the context menu for the ListView. The context menu is displayed whenever the user right clicks inside the ListView.
void | SetModel (ModelRef model)
Set the data model used by the ListView.
void | SetRowHeight (int height=DefaultRowHeight)
Sets the height of the rows displayed in the ListView.
void | SetScrollBarVisibility (ScrollBar scrollBar, bool isVisible)
Sets the specified scrollbar's visibility.
bool | StripedBackgroundEnabled () const
Returns true if the view alternates row background color.

Public Attributes

ColumnClickedEvent ColumnClicked
Emitted when a Column is clicked.
HotCellChangedEvent HotCellChanged
Emitted when the the mouse cursor has entered a new cell.
HotRowChangedEvent HotRowChanged
Emitted when the the mouse cursor has entered a new row.
RowActivatedEvent RowActivated
Emitted when the the mousebutton doubleclicks on a row.
SelectionChangedEvent SelectionChanged
Emitted when the selection has changed.

Classes

class | CellRenderer
Used for rendering a (rowIndex, Column) pair. More...
class | Column
Represents a Column of data in a ListView. More...
class | InvalidColumnException
class | InvalidSelectionTypeException
class | Model
Supplies one or more ListView instances with data to display. More...
class | RowRenderer
Used for rendering rows in the ListView. More...
class | TextCellRenderer
The default CellRenderer. More...

Detailed Description

A ListView is used for displaying data in row/column format.

The ListView class wraps a Win32 WC_LISTVIEW with LVS_OWNERDATA; all data is virtualized. In other words, data isn't stuffed into the view. Rather, the ListView asks a ListView::Model to supply it with data as needed. This makes displaying large amounts of data extremely efficient.

ListView also supports custom drawing via CellRenderer and RowRenderer objects. The model can optionally supply custom renderers to easily change the appearance of the view.

See also:
Window

Member Typedef Documentation

typedef sigslot::signal2<ListView*, ColumnRef> win32cpp::ListView::ColumnClickedEvent

typedef sigslot::signal3<ListView* , int , ColumnRef> win32cpp::ListView::HotCellChangedEvent

typedef sigslot::signal2<ListView* , int > win32cpp::ListView::HotRowChangedEvent

typedef sigslot::signal2<ListView* , int > win32cpp::ListView::RowActivatedEvent

typedef std::vector<int> win32cpp::ListView::RowIndexList

typedef sigslot::signal1<ListView* > win32cpp::ListView::SelectionChangedEvent

Member Function Documentation

void ListView::AddColumn ( ColumnRef column )

Adds the specified column to the view.

See also:
ListView::RemoveColumn

bool ListView::CellAtPoint | ( | const Point & | location,
 |  | int & | rowIndex,
 |  | ColumnRef & | column |
 | ) |  |  | const

Returns the row index and column at the specified Point.

Parameters:
location | The point to test. The coordinates should be relative to the ListView.
rowIndex | An int reference to receive the row index.
column | A ColumnRef reference to receive the ColumnRef.
Returns:
true if the location specified is under a valid row and column.
See also:
ListView::RowAtPoint

bool ListView::ColumnsVisible ( ) const

Returns true if the column headers are visible, false otherwise.

See also:
ListView::SetColumnsVisible

int ListView::ColumnWidth ( ColumnRef column ) const

Returns the width of the specified column.

Parameters:
column The column to query.
Returns:
The width of the specified column.
See also:
ListView::SetColumnWidth

void ListView::EnableColumnResizing ( bool enable )

Enables column resizing via click and drag.

Parameters:
enable if true column resizing will be enabled.
See also:
ListView::ResizableColumnsEnabled

void ListView::EnableMultipleSelection ( bool enable )

Enables multiple row selection.

Parameters:
enable if true multiple row selection will be enabled.
See also:
ListView::MultipleSelectionEnabled

void ListView::EnableStripedBackground ( bool enable )

Enables alternating row background color.

Parameters:
enable if true alternating row color will be enabled.
See also:
ListView::StripedBackgroundEnabled

ListView::ColumnRef ListView::HotColumn ( ) const

Returns the Column currently under the mouse cursor.

Users should check this value to assure it is valid, as it is possible for the mouse to not be under a Column.

Returns:
The Column currently under the mouse cursor.
See also:
ListView::HotColumn

int ListView::HotRow ( ) const

Returns the index of the row currently under the mouse cursor.

Returns:
The index of the row currently under the mouse cursor; -1 if the cursor is not under a row.
See also:
ListView::HotColumn

bool ListView::MultipleSelectionEnabled ( ) const

Returns true if multiple row selection is enabled.

See also:
ListView::EnableMultipleSelection

void ListView::RedrawCell | ( | int | rowIndex,
 |  | ColumnRef | column |
 | ) |  |  | const

Redraw the cell at the specified index and Column.

Parameters:
rowIndex | The index of the row to redraw.
column | The Column within the specified row index to redraw.
See also:
ListView::RedrawRow

void ListView::RedrawRow ( int rowIndex ) const

Redraw the row at the specified index.

Parameters:
rowIndex The index of the row to redraw.
See also:
ListView::RedrawCell

void ListView::RemoveColumn ( ColumnRef column )

Removes the specified column from the view.

See also:
ListView::AddColumn

bool ListView::ResizableColumnsEnabled ( ) const

Returns true if column resizing is enabled.

See also:
ListView::EnableColumnResizing

int ListView::RowAtPoint ( const Point & location ) const

Returns the index of the row under the specified Point.

Parameters:
location The point to test. The coordinates should be relative to the ListView.
Returns:
The index of the row under the specified point.
See also:
ListView::CellAtPoint

int ListView::RowHeight ( ) const

Returns the height of the rows displayed in the ListView.

See also:
ListView::SetRowHeight

void ListView::ScrollToRow ( int rowIndex )

Scrolls the ListView to assure the item at rowIndex is visible.

Parameters:
rowIndex The index of the row to scroll to.

int ListView::SelectedRow ( )

Returns the index of the selected row.

Exceptions:
InvalidSelectionTypeException if multiple selection is enabled.
See also:
ListView::SelectedRow

ListView::RowIndexList ListView::SelectedRows ( )

Returns a std::vector<int> that contains the selected row indices.

Exceptions:
InvalidSelectionTypeException if multiple selection is disabled.
See also:
ListView::SelectedRow

void ListView::SetColumnsVisible ( bool visible )

Set the visibility of the column header.

Parameters:
visible if true the column header will be visible, otherwise it will be hidden.
See also:
ListView::ColumnsVisible

bool ListView::SetColumnWidth | ( | ColumnRef | column,
 |  | int | width
 | ) |  |

Sets the width of the specified column.

Parameters:
column | The column to update.
width | The requested width of the column, in pixels.
Returns:
true if successful, false otherwise.
See also:
ListView::ColumnWidth

void ListView::SetModel ( ModelRef model )

Set the data model used by the ListView.

All displayed data, including ListView::RowRenderer's and ListView::CellRenderer's are obtained from the model.

Parameters:
model A shared pointer to a Listview::Model
See also:
ListView::Model, ListView::ModelRef

void ListView::SetRowHeight ( int rowHeight = DefaultRowHeight )

Sets the height of the rows displayed in the ListView.

Parameters:
rowHeight The height of the row, in pixels
See also:
ListView::RowHeight

void ListView::SetScrollBarVisibility | ( | ScrollBar | scrollBar,
 |  | bool | isVisible
 | ) |  |

Sets the specified scrollbar's visibility.

Parameters:
scrollBar | The scrollbar whose visibility will be changed
isVisible | If true the scrollbar will be visible; if false the scrollbar will be hidden.
See also:
ScrollBar

bool ListView::StripedBackgroundEnabled ( ) const

Returns true if the view alternates row background color.

See also:
ListView::EnableStripedBackground


win32cpp: Member List

win32cpp::ListView Member List

This is the complete list of members for win32cpp::ListView, including all inherited members.

AddColumn(ColumnRef column) | win32cpp::ListView |
BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
CellAtPoint(const Point &location, int &rowIndex, ColumnRef &column) const | win32cpp::ListView |
CellRendererRef typedef | win32cpp::ListView |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
ColumnClicked | win32cpp::ListView |
ColumnClickedEvent typedef | win32cpp::ListView |
ColumnRef typedef | win32cpp::ListView |
ColumnsVisible() const | win32cpp::ListView |
ColumnWidth(ColumnRef column) const | win32cpp::ListView |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
EnableColumnResizing(bool enable) | win32cpp::ListView |
EnableMultipleSelection(bool enable) | win32cpp::ListView |
EnableStripedBackground(bool enable) | win32cpp::ListView |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
HotCellChanged | win32cpp::ListView |
HotCellChangedEvent typedef | win32cpp::ListView |
HotColumn() const | win32cpp::ListView |
HotRow() const | win32cpp::ListView |
HotRowChanged | win32cpp::ListView |
HotRowChangedEvent typedef | win32cpp::ListView |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
ListView() | win32cpp::ListView |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
ModelRef typedef | win32cpp::ListView |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
MultipleSelectionEnabled() const | win32cpp::ListView |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
RedrawCell(int rowIndex, ColumnRef column) const | win32cpp::ListView |
RedrawRow(int rowIndex) const | win32cpp::ListView |
RemoveColumn(ColumnRef column) | win32cpp::ListView |
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
ResizableColumnsEnabled() const | win32cpp::ListView |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
RowActivated | win32cpp::ListView |
RowActivatedEvent typedef | win32cpp::ListView |
RowAtPoint(const Point &location) const | win32cpp::ListView |
RowHeight() const | win32cpp::ListView |
RowIndexList typedef | win32cpp::ListView |
RowRendererRef typedef | win32cpp::ListView |
ScrollToRow(int rowIndex) | win32cpp::ListView |
SelectedRow() | win32cpp::ListView |
SelectedRows() | win32cpp::ListView |
SelectionChanged | win32cpp::ListView |
SelectionChangedEvent typedef | win32cpp::ListView |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetColumnsVisible(bool visible) | win32cpp::ListView |
SetColumnWidth(ColumnRef column, int width) | win32cpp::ListView |
SetContextMenu(MenuRef contextMenu) | win32cpp::ListView |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetModel(ModelRef model) | win32cpp::ListView |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetRowHeight(int height=DefaultRowHeight) | win32cpp::ListView |
SetScrollBarVisibility(ScrollBar scrollBar, bool isVisible) | win32cpp::ListView |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
StripedBackgroundEnabled() const | win32cpp::ListView |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::ListView::CellRenderer Class Reference

win32cpp::ListView::CellRenderer

win32cpp::ListView::CellRenderer Class Reference

Used for rendering a (rowIndex, Column) pair. More...

#include <ListView.hpp>

Inheritance diagram for win32cpp::ListView::CellRenderer:

[legend]

List of all members.

Public Member Functions

virtual void Render (const ListView &listView, RenderParams &renderParams)=0
Render the cell with the parameters of renderParams.

Detailed Description

Used for rendering a (rowIndex, Column) pair.

The default CellRenderer, TextCellRenderer, renders any class that supports the output stream operator <<

CellRenderers are usually passed by shared pointer (CellRendererRef), e.g.

   CellRendererRef cellRenderer(new MyCellRenderer());

See also:
ListView::RowRenderer

Member Function Documentation

virtual void win32cpp::ListView::CellRenderer::Render | ( | const ListView & | listView,
 |  | RenderParams & | renderParams |
 | ) |  |  | [pure virtual]

Render the cell with the parameters of renderParams.

Parameters:
listView | The parent ListView.
renderParams | The suggested draw parameters.

Implemented in win32cpp::ListView::TextCellRenderer< T >.


win32cpp: Member List

win32cpp::ListView::CellRenderer Member List

This is the complete list of members for win32cpp::ListView::CellRenderer, including all inherited members.

Render(const ListView &listView, RenderParams &renderParams)=0 win32cpp::ListView::CellRenderer [pure virtual]


win32cpp: win32cpp::ListView::Column Class Reference

win32cpp::ListView::Column

win32cpp::ListView::Column Class Reference

Represents a Column of data in a ListView. More...

#include <ListView.hpp>

List of all members.

Public Member Functions

virtual TextAlignment | Alignment ()
Returns requested text alignment of the column.
virtual int | DefaultWidth ()
Returns default display width of the column.
virtual const uichar * | Name ()
Returns the display name of the column.

Protected Member Functions

Column (const uichar *name, int defaultWidth=100, TextAlignment alignment=TextAlignLeft)
Constructor.

Detailed Description

Represents a Column of data in a ListView.

Columns are typically passed around in the form of a ColumnRef, a shared pointer to a Column. It is best to create them as follows:

   ColumnRef myColumn(new Column(_T("My Column")));

See also:
ListView::ColumnRef

Constructor & Destructor Documentation

win32cpp::ListView::Column::Column | ( | const uichar * | name,
 |  | int | defaultWidth = 100,
 |  | TextAlignment | alignment = TextAlignLeft |
 | ) |  |  | [inline, protected]

Constructor.

Parameters:
name | Name of the column.
defaultWidth | The default width of the column, in pixels
alignment | The Column's text alignment


win32cpp: Member List

win32cpp::ListView::Column Member List

This is the complete list of members for win32cpp::ListView::Column, including all inherited members.

Alignment() | win32cpp::ListView::Column | [inline, virtual]
Column(const uichar *name, int defaultWidth=100, TextAlignment alignment=TextAlignLeft) | win32cpp::ListView::Column | [inline, protected]
DefaultWidth() | win32cpp::ListView::Column | [inline, virtual]
Name() | win32cpp::ListView::Column | [inline, virtual]


win32cpp: win32cpp::ListView::InvalidColumnException Class Reference

win32cpp::ListView::InvalidColumnException

win32cpp::ListView::InvalidColumnException Class Reference

Inheritance diagram for win32cpp::ListView::InvalidColumnException:

[legend]

List of all members.

Detailed Description

Generated on Wed Sep 3 17:44:07 2008 for win32cpp by doxygen 1.5.6


win32cpp: Member List

win32cpp::ListView::InvalidColumnException Member List

This is the complete list of members for win32cpp::ListView::InvalidColumnException, including all inherited members.

Exception() | win32cpp::Exception |
Exception(const char *message) | win32cpp::Exception |
Message() | win32cpp::Exception | [virtual]


win32cpp: win32cpp::ListView::InvalidSelectionTypeException Class Reference

win32cpp::ListView::InvalidSelectionTypeException

win32cpp::ListView::InvalidSelectionTypeException Class Reference

Inheritance diagram for win32cpp::ListView::InvalidSelectionTypeException:

[legend]

List of all members.

Detailed Description

Generated on Wed Sep 3 17:44:07 2008 for win32cpp by doxygen 1.5.6


win32cpp: Member List

win32cpp::ListView::InvalidSelectionTypeException Member List

This is the complete list of members for win32cpp::ListView::InvalidSelectionTypeException, including all inherited members.

Exception() | win32cpp::Exception |
Exception(const char *message) | win32cpp::Exception |
Message() | win32cpp::Exception | [virtual]


win32cpp: win32cpp::ListView::Model Class Reference

win32cpp::ListView::Model

win32cpp::ListView::Model Class Reference

Supplies one or more ListView instances with data to display. More...

#include <ListView.hpp>

Inherited by win32cpp::ListView::NullModel.

List of all members.

Public Types

typedef sigslot::signal1< int > | DataChangedEvent
typedef sigslot::signal0 | RowCountChangedEvent

Public Member Functions

virtual CellRendererRef | CellRenderer (int rowIndex, ColumnRef column)
Returns a CellRenderer for the specified (rowIndex, Column).
virtual uistring | CellValueToString (int rowIndex, ColumnRef column)=0
Returns a string representation of the value at (rowIndex, Column).
Model (int rowCount=0)
Constructor.
int | RowCount ()
Returns the number of rows in the Model.
virtual RowRendererRef | RowRenderer (int rowIndex)
Returns a RowRenderer for the specified row index.

Public Attributes

DataChangedEvent DataChanged
Emitted when data in the model has been updated.
RowCountChangedEvent RowCountChanged
Emitted when the number of rows has changed.

Protected Member Functions

void | SetRowCount (int rowCount)
Sets the number of rows in the Model.

Detailed Description

Supplies one or more ListView instances with data to display.

The user must subclass Model and override Model::CellValueToString to get data into the ListView.

   class MyModel: public ListView::Model
   {
   public:
       virtual uistring CellValueToString(int rowIndex, ColumnRef column)
       {
           // a real implementation would do something more useful!
           return _T("value at rowIndex, column");
       }
   };

   class MyController
   {
   private:
       //...
       void OnViewCreated();
       ListView::ModelRef model;
       ListView& listView;
   };

   void MyController::OnViewCreated()
   {
       //...
       // Create an instance of MyModel and give it to the view.
       this->model.reset(new MyModel());
       this->listView.SetModel(this->model);

       // SetRowCount will emit a RowCountChanged event, which the
       // ListView listens for. Once the row count is set, the ListView
       // will call Model::CellValueToString to display the data.
       this->model->SetRowCount(60);
       //...
   };

Model instances are usually passed by shared pointer, so it's best to create and use them as follows:

   ModelRef myModel(new MyModel());

A single ListView::ModelRef can be shared amongst multiple ListView instances.

A Model can also be used to (optionally) provide the ListView with custom RowRenderer and CellRenderer instances to drastically change the appearance of the view.

See also:
ListView, ListView::RowRenderer, ListView::CellRenderer

Member Typedef Documentation

typedef sigslot::signal1<int> win32cpp::ListView::Model::DataChangedEvent

typedef sigslot::signal0 win32cpp::ListView::Model::RowCountChangedEvent

Constructor & Destructor Documentation

win32cpp::ListView::Model::Model ( int rowCount = 0 ) [inline]

Constructor.

Parameters:
rowCount The number of rows to initialize the Model with.

Member Function Documentation

virtual CellRendererRef win32cpp::ListView::Model::CellRenderer | ( | int | rowIndex,
 |  | ColumnRef | column |
 | ) |  |  | [inline, virtual]

Returns a CellRenderer for the specified (rowIndex, Column).

If no CellRenderer is returned the ListView will use a TextCellRenderer with the value obtained by Model::CellValueToString

Parameters:
rowIndex | The row index of interest.
column | The Column of the row.
Returns:
A CellRenderer for the specified (rowIndex, Column)
See also:
Model::RowRenderer, Model::CellValueToString.

virtual uistring win32cpp::ListView::Model::CellValueToString | ( | int | rowIndex,
 |  | ColumnRef | column |
 | ) |  |  | [pure virtual]

Returns a string representation of the value at (rowIndex, Column).

This is the only pure virtual method of the class, and must be overriden.

Parameters:
rowIndex | The rowIndex.
column | The Column.
Returns:
A string representation of the value at (rowIndex, Column)

virtual RowRendererRef win32cpp::ListView::Model::RowRenderer ( int rowIndex ) [inline, virtual]

Returns a RowRenderer for the specified row index.

If no RowRenderer is returned the ListView will fill the row with the default background color.

Parameters:
rowIndex The row index of interest.
Returns:
A RowRenderer for the specified row index
See also:
Model::CellRenderer, Model::CellValueToString.

void win32cpp::ListView::Model::SetRowCount ( int rowCount ) [inline, protected]

Sets the number of rows in the Model.

This method will cause RowCountChanged to be emitted.

Parameters:
rowCount The new number of rows.


win32cpp: Member List

win32cpp::ListView::Model Member List

This is the complete list of members for win32cpp::ListView::Model, including all inherited members.

CellRenderer(int rowIndex, ColumnRef column) | win32cpp::ListView::Model | [inline, virtual]
CellValueToString(int rowIndex, ColumnRef column)=0 | win32cpp::ListView::Model | [pure virtual]
DataChanged | win32cpp::ListView::Model |
DataChangedEvent typedef | win32cpp::ListView::Model |
Model(int rowCount=0) | win32cpp::ListView::Model | [inline]
RowCount() | win32cpp::ListView::Model | [inline]
RowCountChanged | win32cpp::ListView::Model |
RowCountChangedEvent typedef | win32cpp::ListView::Model |
RowRenderer(int rowIndex) | win32cpp::ListView::Model | [inline, virtual]
SetRowCount(int rowCount) | win32cpp::ListView::Model | [inline, protected]


win32cpp: win32cpp::ListView::RowRenderer Class Reference

win32cpp::ListView::RowRenderer

win32cpp::ListView::RowRenderer Class Reference

Used for rendering rows in the ListView. More...

#include <ListView.hpp>

List of all members.

Public Member Functions

virtual void Render (const ListView &listView, RenderParams &renderParams)
Render the background of listView to with the parameters of renderParams.

Detailed Description

Used for rendering rows in the ListView.

RowRenderers typically prepare the background for CellRenderers, e.g. by drawing alternating background color. CellRenderers are used to draw the contents of a specific (rowIndex, Column) pair.

The default RowRenderer just fills the the background with renderParams.backColor.

RowRenderers are usually passed by shared pointer (RowRendererRef), e.g.

   RowRendererRef rowRenderRef(new MyRowRenderer());

See also:
ListView::CellRenderer

Member Function Documentation

void ListView::RowRenderer::Render | ( | const ListView & | listView,
 |  | RenderParams & | renderParams |
 | ) |  |  | [virtual]

Render the background of listView to with the parameters of renderParams.

Parameters:
listView | The parent ListView.
renderParams | The suggested draw parameters.


win32cpp: Member List

win32cpp::ListView::RowRenderer Member List

This is the complete list of members for win32cpp::ListView::RowRenderer, including all inherited members.

Render(const ListView &listView, RenderParams &renderParams) win32cpp::ListView::RowRenderer [virtual]


win32cpp: win32cpp::ListView::TextCellRenderer< T > Class Template Reference

win32cpp::ListView::TextCellRenderer

win32cpp::ListView::TextCellRenderer< T > Class Template Reference

The default CellRenderer. More...

#include <ListView.hpp>

Inheritance diagram for win32cpp::ListView::TextCellRenderer< T >:

[legend]

List of all members.

Public Member Functions

void Render (const ListView &listView, RenderParams &renderParams)
Render the cell with the parameters of renderParams.
TextCellRenderer (const T &value, TextAlignment alignment=TextAlignLeft)
Constructor.

Detailed Description

template<typename T>
class win32cpp::ListView::TextCellRenderer< T >

The default CellRenderer.

Renders any class that supports the output stream operator <<

See also:
ListView::CellRenderer

Constructor & Destructor Documentation

template<typename T>
win32cpp::ListView::TextCellRenderer< T >::TextCellRenderer | ( | const T & | value,
 |  | TextAlignment | alignment = TextAlignLeft |
 | ) |  |  | [inline]

Constructor.

Parameters:
value | The value to render
alignment | The alignment to use

Member Function Documentation

template<typename T>
void win32cpp::ListView::TextCellRenderer< T >::Render | ( | const ListView & | listView,
 |  | RenderParams & | renderParams |
 | ) |  |  | [inline, virtual]

Render the cell with the parameters of renderParams.

Parameters:
listView | The parent ListView.
renderParams | The suggested draw parameters.

Implements win32cpp::ListView::CellRenderer.


win32cpp: Member List

win32cpp::ListView::TextCellRenderer< T > Member List

This is the complete list of members for win32cpp::ListView::TextCellRenderer< T >, including all inherited members.

Render(const ListView &listView, RenderParams &renderParams) | win32cpp::ListView::TextCellRenderer< T > | [inline, virtual]
TextCellRenderer(const T &value, TextAlignment alignment=TextAlignLeft) | win32cpp::ListView::TextCellRenderer< T > | [inline]


win32cpp: win32cpp::MemoryDC Class Reference

win32cpp::MemoryDC

win32cpp::MemoryDC Class Reference

A memory device context. MemoryDC is used internally by various classes, including Window, for flicker free drawing. More...

#include <MemoryDC.hpp>

List of all members.

Public Member Functions

MemoryDC (HDC hdc, const RECT &rect)
Constructor.
operator HDC ()
Returns a handle to the offscreen device context.

Detailed Description

A memory device context. MemoryDC is used internally by various classes, including Window, for flicker free drawing.

When performing graphics operations on a Window's DC, changes are drawn directly to screen; this leads to flickering. MemoryDC creates an offscreen buffer that "accumulates" changes, which are copied to a desination DC when all drawing has finished.

MemoryDC is constructed with an HDC and a Rect as parameters, and provides an implicit HDC cast operator that returns a handle to the offscreen buffer. This means that regular Win32 drawing routines, such as DrawLine, FillRect, etc, can transparently use a MemoryDC as if it were a regular HDC.

When a MemoryDC's destructor is called the contents of the offscren buffer are automatically copied to to the HDC it was constructed with, resulting in flicker-free drawing.

   PAINTSTRUCT paintStruct;
   HDC hdc = ::BeginPaint(this->Handle(), &paintStruct);
   {
       MemoryDC memDC(hdc, paintStruct.rcPaint);

       //...
       //draw to memDC as if you were drawing to hdc
       //...

   } // when the MemoryDC destructor is called, the contents will be copied to hdc
   ::EndPaint(this->Handle(), &paintStruct);

See also:
RedrawLock

Constructor & Destructor Documentation

MemoryDC::MemoryDC | ( | HDC | hdc,
 |  | const RECT & | rect
 | ) |  |

Constructor.

Parameters:
hdc | The destination HDC. The final contents of the memory buffer will be copied here upon destruction.
rect | The Rectangle that represents the drawable area of the HDC.


win32cpp: Member List

win32cpp::MemoryDC Member List

This is the complete list of members for win32cpp::MemoryDC, including all inherited members.

MemoryDC(HDC hdc, const RECT &rect) | win32cpp::MemoryDC
operator HDC() | win32cpp::MemoryDC


win32cpp: win32cpp::NotImplementedException Class Reference

win32cpp::NotImplementedException

win32cpp::NotImplementedException Class Reference

Thrown when a method is not yet implemented. More...

#include <Exception.hpp>

Inheritance diagram for win32cpp::NotImplementedException:

[legend]

List of all members.

Detailed Description

Thrown when a method is not yet implemented.


win32cpp: Member List

win32cpp::NotImplementedException Member List

This is the complete list of members for win32cpp::NotImplementedException, including all inherited members.

Exception() | win32cpp::Exception |
Exception(const char *message) | win32cpp::Exception |
Message() | win32cpp::Exception | [virtual]


win32cpp: win32cpp::Panel Class Reference

win32cpp::Panel

win32cpp::Panel Class Reference

Panel is the most basic concrete implementation of Container. More...

#include <Panel.hpp>

Inheritance diagram for win32cpp::Panel:

[legend]

List of all members.

Public Member Functions

Panel ()
Default constructor.

Detailed Description

Panel is the most basic concrete implementation of Container.

Panel does not offer any special layout functionality, and has no limitations as to the number of child controls that can be added. Panel is the base class for most more advanced Container implementations, including Splitter and BoxLayout.

See also:
BoxLayout, Splitter


win32cpp: Member List

win32cpp::Panel Member List

This is the complete list of members for win32cpp::Panel, including all inherited members.

AddChild(WindowType *window) | win32cpp::Container | [inline]
BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Panel() | win32cpp::Panel |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
RemoveChild(WindowType *window) | win32cpp::Container | [inline]
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::Point Struct Reference

win32cpp::Point

win32cpp::Point Struct Reference

Represents a point. More...

#include <WindowGeometry.hpp>

List of all members.

Public Member Functions

operator POINT () const
Returns a Win32 POINT object representation of the Point.
Point (const POINT &pt)
Constructor.
Point (int x, int y)
Constructor.
Point ()
constructor.

Public Attributes

int | x
The X location of the point.
int | y
The Y location of the point.

Detailed Description

Represents a point.


win32cpp: Member List

win32cpp::Point Member List

This is the complete list of members for win32cpp::Point, including all inherited members.

operator POINT() const | win32cpp::Point | [inline]
Point() | win32cpp::Point | [inline]
Point(int x, int y) | win32cpp::Point | [inline]
Point(const POINT &pt) | win32cpp::Point | [inline]
x | win32cpp::Point |
y | win32cpp::Point |


win32cpp: win32cpp::ProgressBar Class Reference

win32cpp::ProgressBar

win32cpp::ProgressBar Class Reference

A progress bar. More...

#include <ProgressBar.hpp>

Inheritance diagram for win32cpp::ProgressBar:

[legend]

List of all members.

Public Member Functions

ProgressBar (int width, int height)
Constructor.
void | SetMarqueeStyle ()
Sets the progress bar to have a smooth bar.
void | SetPos (int pos)
Sets the current position of the progress bar.
void | SetRange (unsigned int min, unsigned int max)
Sets the min and max values of the progress bar.
void | SetSmoothStyle ()
Sets the progress bar to have a smooth bar.
void | SetStepIncrement (int inc)
Sets the current position of the progress bar.
void | SetVerticalStyle ()
Sets the progress bar to have a smooth bar.
void | StartMarquee (bool set, unsigned int delay)
Sets the progress bar to have a marquee style (Windows XP or above).
void | Step ()
Steps the progress bar forward once. Default step is 10.

Detailed Description

A progress bar.

Constructor & Destructor Documentation

ProgressBar::ProgressBar | ( | int | width,
 |  | int | height
 | ) |  |

Constructor.

Parameters:
width | The width of the edit box
height | The height of the edit box

Member Function Documentation

void ProgressBar::SetPos ( int pos )

Sets the current position of the progress bar.

Parameters:
pos The new position of the progress bar

void ProgressBar::SetRange | ( | unsigned int | min,
 |  | unsigned int | max
 | ) |  |

Sets the min and max values of the progress bar.

Parameters:
min | The minimum value (unsigned)
max | The maximum value (unsigned)

void ProgressBar::SetStepIncrement ( int inc )

Sets the current position of the progress bar.

Parameters:
pos The new step increment

void ProgressBar::StartMarquee | ( | bool | set,
 |  | unsigned int | delay
 | ) |  |

Sets the progress bar to have a marquee style (Windows XP or above).

Parameters:
set | Boolean to say whether to marquee or not
delay | Time in milliseconds between animation updates


win32cpp: Member List

win32cpp::ProgressBar Member List

This is the complete list of members for win32cpp::ProgressBar, including all inherited members.

BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
ProgressBar(int width, int height) | win32cpp::ProgressBar |
Redraw() const | win32cpp::Window |
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMarqueeStyle() | win32cpp::ProgressBar |
SetMenu(MenuRef menu) | win32cpp::Window |
SetPos(int pos) | win32cpp::ProgressBar |
SetRange(unsigned int min, unsigned int max) | win32cpp::ProgressBar |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetSmoothStyle() | win32cpp::ProgressBar |
SetStepIncrement(int inc) | win32cpp::ProgressBar |
SetTabStop(bool enabled) | win32cpp::Window |
SetVerticalStyle() | win32cpp::ProgressBar |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
StartMarquee(bool set, unsigned int delay) | win32cpp::ProgressBar |
Step() | win32cpp::ProgressBar |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::RadioButton Class Reference

win32cpp::RadioButton

win32cpp::RadioButton Class Reference

A standard RadioButton. They are organised as linked list to enforce the grouping behaviour. More...

#include <RadioButton.hpp>

Inheritance diagram for win32cpp::RadioButton:

[legend]

List of all members.

Public Member Functions

uistring Caption (void) const
Returns the caption of the Window.
RadioButton (const uichar *caption=_T(""), RadioButton *attach=NULL)
Constructor.

Public Attributes

RadioButtonPressedEvent Pressed
This event is emitted when the user presses the RadioButton.

Detailed Description

A standard RadioButton. They are organised as linked list to enforce the grouping behaviour.

Constructor & Destructor Documentation

RadioButton::RadioButton | ( | const uichar * | caption = _T(""),
 |  | RadioButton * | prev = NULL
 | ) |  |

Constructor.

Parameters:
caption The caption beside the radio button

Member Function Documentation

uistring win32cpp::RadioButton::Caption ( void ) const [inline]

Returns the caption of the Window.

Internally this method uses Win32's GetWindowText

Reimplemented from win32cpp::Window.


win32cpp: Member List

win32cpp::RadioButton Member List

This is the complete list of members for win32cpp::RadioButton, including all inherited members.

BackgroundColor() const | win32cpp::Window |
Caption(void) const | win32cpp::RadioButton | [inline]
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Pressed | win32cpp::RadioButton |
RadioButton(const uichar *caption=_T(""), RadioButton *attach=NULL) | win32cpp::RadioButton |
Redraw() const | win32cpp::Window |
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::Rect Struct Reference

win32cpp::Rect

win32cpp::Rect Struct Reference

Represents a rectangle. More...

#include <WindowGeometry.hpp>

List of all members.

Public Member Functions

int | Height ()
Returns the height of the rectangle.
operator RECT () const
Returns a Win32 RECT object representation of the Point.
Rect (const RECT &rect)
constructor.
Rect (const Point &location, const Size &size)
constructor.
Rect ()
constructor.
int | Width ()
Returns the width of the rectangle.
int | X ()
Returns the X coordinate of the upper-left corner.
int | Y ()
Returns the Y coordinate of the upper-left corner.

Public Attributes

Point location
The location of the upper left corner of the rectangle.
Size size
The size of the rectangle.

Detailed Description

Represents a rectangle.


win32cpp: Member List

win32cpp::Rect Member List

This is the complete list of members for win32cpp::Rect, including all inherited members.

Height() | win32cpp::Rect | [inline]
location | win32cpp::Rect |
operator RECT() const | win32cpp::Rect | [inline]
Rect() | win32cpp::Rect | [inline]
Rect(const Point &location, const Size &size) | win32cpp::Rect | [inline]
Rect(const RECT &rect) | win32cpp::Rect | [inline]
size | win32cpp::Rect |
Width() | win32cpp::Rect | [inline]
X() | win32cpp::Rect | [inline]
Y() | win32cpp::Rect | [inline]


win32cpp: win32cpp::RedrawLock Struct Reference

win32cpp::RedrawLock

win32cpp::RedrawLock Struct Reference

Use RedrawLock to stop the specified Window from being redrawn. Redrawing is automatically enabled on the Window when the RedrawLock's destructor is called. More...

#include <RedrawLock.hpp>

List of all members.

Public Member Functions

RedrawLock (Window *window)
Constructor.

Detailed Description

Use RedrawLock to stop the specified Window from being redrawn. Redrawing is automatically enabled on the Window when the RedrawLock's destructor is called.

RedrawLock uses the the WM_SETREDRAW message, see. For more information see http://msdn2.microsoft.com/en-us/library/ms534853.aspx

   Splitter* mySplitter = ...;
   {
       RedrawLock redrawLock(mySplitter)

        //...
        //perform operations to mySplitter
        //...

   } // mySplitter will be redrawn when redrawLock's destructor is called

RedrawLock is safe against locking the same Window multiple times, recursively. The Window will not be redrawn until all locks have been destructed.

Constructor & Destructor Documentation

RedrawLock::RedrawLock ( Window * window )

Constructor.

Parameters:
window The Window whose redraw will be locked


win32cpp: Member List

win32cpp::RedrawLock Member List

This is the complete list of members for win32cpp::RedrawLock, including all inherited members.

RedrawLock(Window *window) win32cpp::RedrawLock


win32cpp: win32cpp::Size Struct Reference

win32cpp::Size

win32cpp::Size Struct Reference

Represents a size. More...

#include <WindowGeometry.hpp>

List of all members.

Public Member Functions

operator SIZE () const
Returns a Win32 SIZE object representation of the Point.
Size (const SIZE &sz)
constructor.
Size (int width, int height)
constructor.
Size ()
constructor.

Public Attributes

int | height
The height, in pixels.
int | width
The width, in pixels.

Detailed Description

Represents a size.


win32cpp: Member List

win32cpp::Size Member List

This is the complete list of members for win32cpp::Size, including all inherited members.

height | win32cpp::Size |
operator SIZE() const | win32cpp::Size | [inline]
Size() | win32cpp::Size | [inline]
Size(int width, int height) | win32cpp::Size | [inline]
Size(const SIZE &sz) | win32cpp::Size | [inline]
width | win32cpp::Size |


win32cpp: win32cpp::Splitter Class Reference

win32cpp::Splitter

win32cpp::Splitter Class Reference

A Container with two children that can be resized with the mouse. More...

#include <Splitter.hpp>

Inheritance diagram for win32cpp::Splitter:

[legend]

List of all members.

Public Member Functions

AnchorDirection Anchor ()
Returns the AnchorDirection of the splitter.
void | AnchorConstraints (int &minSize, int &maxSize)
Returns the minimum and maximum allowed sizes of the anchored child.
const Window * | Child1 ()
Returns the first (left, or top) child.
const Window * | Child2 ()
Returns the second (right, or bottom) child.
bool | IsSizable ()
Returns true if the Splitter can be resized with the mouse, false otherwise.
void | SetAnchor (AnchorDirection newAnchor)
Sets the AnchorDirection of the splitter.
void | SetAnchorConstraints (int minSize=DisableConstraint, int maxSize=DisableConstraint)
Sets the minimum and maximum allowed sizes of the anchored child.
void | SetAnchorSize (int anchorSize)
Sets the new AnchorDirection of the splitter.
Window * | SetChild1 (Window *window)
Set the left (if SplitColumn) or top (if SplitRow) child.
Window * | SetChild2 (Window *window)
Set the right (SplitColumn) or bottom (SplitRow) child.
void | SetGripperSize (int pixels)
Sets the size of the resize gripper, in pixels.
void | SetSizable (bool sizable)
Sets whether or not the Splitter can be resized with the mouse via click and drag.
Splitter (SplitDirection direction, Window *child1=NULL, Window *child2=NULL)
Constructor.

Detailed Description

A Container with two children that can be resized with the mouse.

Splitter works with any two Window derived instances. Adding more than two children will result in a TooManyChildWindowsException.

Splitter will automatically expand its children

   Button* button1 = new Button(_T("button1"));
   Button* button2 = new Button(_T("button2"));
   Splitter* splitter = new Splitter(SplitColumn, button1, button2);
   Application::Instance().MainWindow()->AddChild(splitter);
   splitter->Resize(400, 300);

Typically when a Splitter is resized it's preferable to keep one of the children stationary or "anchored," while allowing the other to be resized to fill the new space. The anchor can be set via Splitter::SetAnchor by specifying a win32cpp::AnchorDirection.

Constructor & Destructor Documentation

Splitter::Splitter | ( | SplitDirection | direction,
 |  | Window * | child1 = NULL,
 |  | Window * | child2 = NULL
 | ) |  |

Constructor.

Parameters:
direction | The split direction, SplitColumn or SplitRow
child1 | The left (horizontal) or top (vertical) child.
child2 | The right (horizontal) or bottom (vertical) child.

Member Function Documentation

AnchorDirection Splitter::Anchor ( )

Returns the AnchorDirection of the splitter.

See also:
Splitter

void Splitter::AnchorConstraints | ( | int & | minSize,
 |  | int & | maxSize
 | ) |  |

Returns the minimum and maximum allowed sizes of the anchored child.

Parameters:
minSize | the minimum size of the anchored child
maxSize | the maximum size of the anchored child

void Splitter::SetAnchor ( AnchorDirection newAnchor )

Sets the AnchorDirection of the splitter.

Parameters:
newAnchor The new AnchorDirection
See also:
Splitter

void Splitter::SetAnchorConstraints | ( | int | minSize = DisableConstraint,
 |  | int | maxSize = DisableConstraint
 | ) |  |

Sets the minimum and maximum allowed sizes of the anchored child.

Clients may pass win32cpp::DisableConstraint to disable contraints.

Parameters:
minSize | the minimum size of the anchored child
maxSize | the maximum size of the anchored child

void Splitter::SetAnchorSize ( int anchorSize )

Sets the new AnchorDirection of the splitter.

The size will be the width if SplitColumn, the height if SplitRow.

Parameters:
anchorSize the new size of the anchor control, in pixels.
See also:
Splitter

Window * Splitter::SetChild1 ( Window * window )

Set the left (if SplitColumn) or top (if SplitRow) child.

The Splitter will assume ownership of the specified Window and will delete it when destroyed.

Parameters:
window The Window to use as a child.
Returns:
The previous child Window. The caller is responsible for freeing the Window.

Window * Splitter::SetChild2 ( Window * window )

Set the right (SplitColumn) or bottom (SplitRow) child.

The Splitter will assume ownership of the specified Window and will delete it when destroyed.

Parameters:
window The Window to use as a child.
Returns:
The previous child Window. The caller is responsible for freeing the Window.


win32cpp: Member List

win32cpp::Splitter Member List

This is the complete list of members for win32cpp::Splitter, including all inherited members.

AddChild(WindowType *window) | win32cpp::Container | [inline]
Anchor() | win32cpp::Splitter |
AnchorConstraints(int &minSize, int &maxSize) | win32cpp::Splitter |
BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
Child1() | win32cpp::Splitter |
Child2() | win32cpp::Splitter |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
IsSizable() | win32cpp::Splitter |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Panel() | win32cpp::Panel |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
RemoveChild(WindowType *window) | win32cpp::Container | [inline]
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetAnchor(AnchorDirection newAnchor) | win32cpp::Splitter |
SetAnchorConstraints(int minSize=DisableConstraint, int maxSize=DisableConstraint) | win32cpp::Splitter |
SetAnchorSize(int anchorSize) | win32cpp::Splitter |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetChild1(Window *window) | win32cpp::Splitter |
SetChild2(Window *window) | win32cpp::Splitter |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetGripperSize(int pixels) | win32cpp::Splitter |
SetMenu(MenuRef menu) | win32cpp::Window |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetSizable(bool sizable) | win32cpp::Splitter |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
Splitter(SplitDirection direction, Window *child1=NULL, Window *child2=NULL) | win32cpp::Splitter |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::SysTray Class Reference

win32cpp::SysTray

win32cpp::SysTray Class Reference

The SysTray class is used for managing icons in the Taskbar. It must be seen as pure manager for the icons in the SysTray bar. Thus there are no special classes for TrayIcons. More...

#include <SysTray.hpp>

List of all members.

Public Member Functions

int | AddIcon (Window *window, HICON icon, const uistring &tooltip=_T(""))
Creates and add a notify icon.
bool | DeleteIcon (UINT uid)
Deletes an icon from the tray and all internal structures.
void | EnableMinimizeToTray (UINT uid)
Activates minimize to tray for the icon specified by uid.
bool | SetIcon (UINT uid, HICON icon)
Sets a new icon for the specified tray icon.
bool | SetPopupMenu (UINT uid, MenuRef menu)
Sets the popup menu for the specified tray icon.
bool | SetTooltip (UINT uid, const uistring &tooltip)
Sets the tooltip for the specified tray icon.
bool | ShowBalloon (UINT uid, const uistring &title, const uistring &text, UINT timeout, UINT icon=NIIF_INFO)
Shows a balloon tip over the tray icon.
LRESULT | WindowProc (HWND window, UINT message, WPARAM wParam, LPARAM lParam)
Window procedure for all SysTray handling. Here WM_RBUTTONDOWN (for popup menu), WM_LBUTTONDOWN (for restoring the window after it has been minimized to tray) & WM_SIZE for the Minimize to tray feature are handled.

Detailed Description

The SysTray class is used for managing icons in the Taskbar. It must be seen as pure manager for the icons in the SysTray bar. Thus there are no special classes for TrayIcons.

Since SysTray communicates using the handle of its associated window, it is necessary, that icons are associated to a window handle.

That's why the SysTray component should NOT be used directly, but from the Application Singleton. Use Application::Instance().SysTrayManager() to get the SysTray object!

Internally each icon has three lists associated:

  • IconList iconList - with NOTIFYICONDATA structures
  • MenuList menuList - with references to win32cpp's MenuRef
  • OptionsList optionsList - option bits are set here

Each notify icon is represted by its unique ID, which is assigned by AddIcon(). Using this ID you can access all other methods.

Code example:

    // Create Menu
    MenuRef myMenu = Menu::CreatePopup();
    myMenu->Items().Append(MenuItem::Create(_T("Test 1")));
    myMenu->Items().Append(MenuItem::Create(_T("Test 2")));
    MenuItemRef trayExit = myMenu->Items().Append(MenuItem::Create(_T("E&xit")));

    // Bind Exit to a handler
    trayExit->Activated.connect(this, &MainWindowController::OnFileExit);

    // Init tray icon
    UINT uidTrayIcon = Application::Instance().SysTrayManager()->AddIcon(Application::Instance().MainWindow(), icon16);
    Application::Instance().SysTrayManager()->SetTooltip(uidTrayIcon, _T("Test");
    Application::Instance().SysTrayManager()->SetPopupMenu(uidTrayIcon, myMenu);
    Application::Instance().SysTrayManager()->ShowBalloon(uidTrayIcon, _T("Test"), _T("Welcome to this application!"), 2);
    Application::Instance().SysTrayManager()->EnableMinimizeToTray(uidTrayIcon);
See also:
Application TopLevelWindow MenuRef

Member Function Documentation

int SysTray::AddIcon | ( | Window * | window,
 |  | HICON | icon,
 |  | const uistring & | tooltip = _T("")
 | ) |  |

Creates and add a notify icon.

Parameters:
window | The window to associate the icon with
icon | The Icon to show as HICON
tooltip | The tooltip to show. Leave it empty to show no tooltip
Returns:
int Returns the new Icon ID or -1 on failure

bool SysTray::DeleteIcon ( UINT uid )

Deletes an icon from the tray and all internal structures.

Parameters:
uid The Icon ID
Returns:

void SysTray::EnableMinimizeToTray ( UINT uid )

Activates minimize to tray for the icon specified by uid.

Parameters:
uid The Icon ID

bool SysTray::SetIcon | ( | UINT | uid,
 |  | HICON | icon
 | ) |  |

Sets a new icon for the specified tray icon.

Parameters:
uid | The Icon ID
icon | New Icon
Returns:

bool SysTray::SetPopupMenu | ( | UINT | uid,
 |  | MenuRef | menu
 | ) |  |

Sets the popup menu for the specified tray icon.

Parameters:
uid | The Icon ID
menu | Reference to the menu which should be displayed
Returns:

bool SysTray::SetTooltip | ( | UINT | uid,
 |  | const uistring & | tooltip
 | ) |  |

Sets the tooltip for the specified tray icon.

Parameters:
uid | The Icon ID
tooltip | Tooltip to show
Returns:

bool SysTray::ShowBalloon | ( | UINT | uid,
 |  | const uistring & | title,
 |  | const uistring & | text,
 |  | UINT | timeout,
 |  | UINT | icon = NIIF_INFO
 | ) |  |

Shows a balloon tip over the tray icon.

Note:
Windows XP is required for this feature!
Parameters:
uid | The Icon ID
title | Balloon title
text | Balloon inner text
timeout | Time to show the balloon in seconds. There are special restrictions defined by the Windows-API. Look here: http://msdn.microsoft.com/en-us/library/bb773352(VS.85).aspx
text | Icon to show. Select from NIIF_NONE, NIIF_INFO, NIIF_WARNING, NIIF_ERROR
Returns:

LRESULT SysTray::WindowProc | ( | HWND | window,
 |  | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Window procedure for all SysTray handling. Here WM_RBUTTONDOWN (for popup menu), WM_LBUTTONDOWN (for restoring the window after it has been minimized to tray) & WM_SIZE for the Minimize to tray feature are handled.

Parameters:
window | Affected window handle
message | Message-ID
wParam
lParam
Returns:
LRESULT In this case always 0


win32cpp: Member List

win32cpp::SysTray Member List

This is the complete list of members for win32cpp::SysTray, including all inherited members.

AddIcon(Window *window, HICON icon, const uistring &tooltip=_T("")) | win32cpp::SysTray
DeleteIcon(UINT uid) | win32cpp::SysTray
EnableMinimizeToTray(UINT uid) | win32cpp::SysTray
SetIcon(UINT uid, HICON icon) | win32cpp::SysTray
SetPopupMenu(UINT uid, MenuRef menu) | win32cpp::SysTray
SetTooltip(UINT uid, const uistring &tooltip) | win32cpp::SysTray
ShowBalloon(UINT uid, const uistring &title, const uistring &text, UINT timeout, UINT icon=NIIF_INFO) | win32cpp::SysTray
WindowProc(HWND window, UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::SysTray


win32cpp: win32cpp::TabView Class Reference

win32cpp::TabView

win32cpp::TabView Class Reference

Panel is the most basic concrete implementation of Container. More...

#include <TabView.hpp>

Inheritance diagram for win32cpp::TabView:

[legend]

List of all members.

Public Member Functions

TabView ()
Default constructor.

Detailed Description

Panel is the most basic concrete implementation of Container.

Panel does not offer any special layout functionality, and has no limitations as to the number of child controls that can be added. Panel is the base class for most more advanced Container implementations, including Splitter and BoxLayout.

See also:
BoxLayout, Splitter


win32cpp: Member List

win32cpp::TabView Member List

This is the complete list of members for win32cpp::TabView, including all inherited members.

AddChild(WindowType *window) | win32cpp::Container | [inline]
BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
RemoveChild(WindowType *window) | win32cpp::Container | [inline]
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
TabStop() | win32cpp::Window |
TabView() | win32cpp::TabView |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::TopLevelWindow Class Reference

win32cpp::TopLevelWindow

win32cpp::TopLevelWindow Class Reference

A TopLevelWindow is a Window with a title bar, menu, and minimize, maximize, close boxes,. More...

#include <TopLevelWindow.hpp>

Inheritance diagram for win32cpp::TopLevelWindow:

[legend]

List of all members.

Public Member Functions

void | Close ()
Closes the TopLevelWindow.
Size | MinimumSize () const
Returns the minimum size of the window.
void | SetMinimumSize (const Size &minSize)
Sets the minimum size of the window.
TopLevelWindow (const uichar *windowTitle)
Constructor.

Detailed Description

A TopLevelWindow is a Window with a title bar, menu, and minimize, maximize, close boxes,.

TopLevelWindows can house an arbitrary number of child windows.

See also:
Window, Container.

Constructor & Destructor Documentation

TopLevelWindow::TopLevelWindow ( const uichar * windowTitle )

Constructor.

Parameters:
windowTitle The title that will be displayed in the title bar..

Member Function Documentation

void TopLevelWindow::SetMinimumSize ( const Size & size )

Sets the minimum size of the window.

Parameters:
size The minimium size.


win32cpp: Member List

win32cpp::TopLevelWindow Member List

This is the complete list of members for win32cpp::TopLevelWindow, including all inherited members.

AddChild(WindowType *window) | win32cpp::Container | [inline]
BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Close() | win32cpp::TopLevelWindow |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MinimumSize() const | win32cpp::TopLevelWindow |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
RemoveChild(WindowType *window) | win32cpp::Container | [inline]
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetMinimumSize(const Size &minSize) | win32cpp::TopLevelWindow |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
TopLevelWindow(const uichar *windowTitle) | win32cpp::TopLevelWindow |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |


win32cpp: win32cpp::Trackbar Class Reference

win32cpp::Trackbar

win32cpp::Trackbar Class Reference

Trackbar allows the user to select a value from a range. More...

#include <Trackbar.hpp>

Inheritance diagram for win32cpp::Trackbar:

[legend]

List of all members.

Public Attributes

TrackbarRepositionedEvent Repositioned
This event is emitted when the position of the slider is changed.

Detailed Description

Trackbar allows the user to select a value from a range.
Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Member List

win32cpp::Trackbar Member List

This is the complete list of members for win32cpp::Trackbar, including all inherited members.

BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
Repositioned | win32cpp::Trackbar |
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |

Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: win32cpp::Win32Exception Class Reference

win32cpp::Win32Exception

win32cpp::Win32Exception Class Reference

An Exception that represents an Win32 error. More...

#include <Win32Exception.hpp>

Inheritance diagram for win32cpp::Win32Exception:

[legend]

List of all members.

Public Member Functions

virtual const char * Message ()
Returns a string representation of the exception, usually a description.

Detailed Description

An Exception that represents an Win32 error.
Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Member List

win32cpp::Win32Exception Member List

This is the complete list of members for win32cpp::Win32Exception, including all inherited members.

Exception() | win32cpp::Exception |
Exception(const char *message) | win32cpp::Exception |
Message() | win32cpp::Win32Exception | [inline, virtual]

Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: win32cpp::Window Class Reference

win32cpp::Window

win32cpp::Window Class Reference

Window is the abstract base class for all controls. More...

#include <Window.hpp>

Inheritance diagram for win32cpp::Window:

[legend]

List of all members.

Public Member Functions

Color | BackgroundColor () const
Returns the Window's background color.
uistring | Caption () const
Returns the caption of the Window.
Rect | ClientRect () const
Returns the Window's client rectangle.
Size | ClientSize () const
Returns the client (content) size of the Window.
Point | CursorPosition () const
Returns the position of the cursor, relative to the Window.
virtual bool | Destroy ()
Destroy the associated HWND.
bool | Enable (bool enable)
Changes the enabled state of the Window.
FontRef | Font () const
Returns a shared pointer to the Font the Window uses to draw its text.
HWND | Handle () const
Returns the HWND that the Window wraps.
void | Initialize (Window *parent=NULL)
Used to force creation of a control. Although this can be called manually it's generally recommended to let Container controls automatically intialize their children.
Point | Location () const
Returns the location of the window, relative to its parent Window.
MenuRef | Menu ()
Returns the Window's Menu.
bool | MoveTo (const Point &location)
Moves the Window to the specified coordinates.
bool | MoveTo (int x, int y)
Moves the Window to the specified coordinates.
Window * | Parent () const
Returns a pointer to the Window's parent.
bool | PostMessage (UINT message, WPARAM wParam, LPARAM lParam)
Asynchronously invokes a message on the Window.
void | Redraw () const
Redraws the Window.
bool | Resize (const Size &size)
Resizes the window to the specified size.
bool | Resize (int width, int height)
Resizes the window to the specified size.
LRESULT | SendMessage (UINT message, WPARAM wParam, LPARAM lParam)
Synchronously invokes a message on the Window.
void | SetBackgroundColor (const Color &color)
Sets the background color of the ListView.
bool | SetCaption (const uistring &caption)
Sets the caption of the Window.
bool | SetFocus ()
Focuses the Window.
void | SetFont (FontRef font)
Sets the Font the Window uses to draw its caption.
void | SetMenu (MenuRef menu)
Sets the Window's Menu.
bool | SetRectangle (const Rect &rectangle)
Moves and resizes the Window to rectangle.location and rectangle.size.
void | SetTabStop (bool enabled)
Sets whether or not this control can be focused via Tab key.
void | SetVisible (bool visible=true)
Shows or hides the window.
bool | Show (int showCommand)
Used to modify the visibility of a Window. Commonly used flags are SW_SHOW and SW_HIDE.
bool | TabStop ()
Returns true if this control should be focused via the Tab key.
bool | Visible ()
Returns true if the window is visible.
Rect | WindowRect () const
Returns the Window's rectangle.
Size | WindowSize () const
Returns the size of the Window.

Public Attributes

KeyEvent Char
Emitted when a key on the keyboard is pressed.
CreatedEvent Created
Emitted when the Window is created. This is not necessarily at construction time, as Windows are lazily created.
DestroyedEvent Destroyed
Emitted when the WM_DESTROY message is received.
FocusEvent GainedFocus
Emitted when the Window has gained focus.
KeyEvent KeyDown
Emitted when a key on the keyboard is pressed down.
KeyEvent KeyUp
Emitted when a key on the keyboard is released.
FocusEvent LostFocus
Emitted when the Window has lost focus.
MouseButtonEvent MouseButtonDoubleClicked
Emitted when a mouse button has been double clicked over the Window.
MouseButtonEvent MouseButtonDown
Emitted when a mouse button has been pressed over the Window.
MouseButtonEvent MouseButtonUp
Emitted when a mouse button has been released over the Window.
MouseEnterEvent MouseEnter
Emitted when the cursor has entered the Window.
MouseExitEvent MouseExit
Emitted when the cursor has left the Window.
MouseMovedEvent MouseMoved
Emitted when the cursor is moved over the Window.
MovedEvent Moved
Emitted when the Window is repositioned.
ParentChangedEvent ParentChanged
Emitted when the Window's parent has changed.
FocusEvent RequestFocusNext
Emitted when a control has requested to focus the next control. This generally shouldn't be handled explicitly unless absolutely necessary.
FocusEvent RequestFocusPrev
Emitted when a control has requested to focus the previous control. This generally shouldn't be handled explicitly unless absolutely necessary.
ResizedEvent Resized
Emitted when the Window is resized.
ThemeChangedEvent ThemeChanged
Emitted when the desktop theme has changed.
TimerEvent TimerTimeout
Emitted when a timer gets a timeout.
VisibilityChangedEvent VisibilityChanged
Emitted when a Window's visibility has changed.

Classes

class | WindowAlreadyCreatedException
This exception will be thrown if Initialize() is called on a Window that has already been created. More...
class | WindowCreationFailedException
This exception is thrown if a Window fails to be created. More...
class | WindowIsNullException
This exception is thrown if a Window parameter is NULL where it shouldn't be. More...
class | WindowNotCreatedException
This exception may be thrown if operations are attempted on a Window that has not been created. More...

Detailed Description

Window is the abstract base class for all controls.

Based on sigslot signals, Window follows the observer/notifier pattern and is able to "emit" notifications to listeners that are not necessarily GUI objects. This promotes use of the model/view/controller design pattern, which is highly recommended. Window also attempts to automatically double buffer all drawing, so controls don't flicker when they are moved or resized. This is accomplished using the MemoryDC and RedrawLock classes.

The Window class also provides "stable" mouse events for derived classes, including consistant cursor enter and exit notifications.

Member Function Documentation

Color Window::BackgroundColor ( ) const

Returns the Window's background color.

See also:
Window::SetBackgroundColor

uistring Window::Caption ( void ) const

Returns the caption of the Window.

Internally this method uses Win32's GetWindowText

Reimplemented in win32cpp::RadioButton.

Rect Window::ClientRect ( ) const

Returns the Window's client rectangle.

The client rectangle is the portion of the Window that content can be displayed. The Window::WindowRect is the bounding rectangle of the entire Window, including borders.

Returns:
the Window's client rectangle.
See also:
Window::WindowRect, Window::SetRectangle

Size Window::ClientSize ( ) const

Returns the client (content) size of the Window.

Not to be confused with Window::WindowSize, Window::ClientSize returns the size of the content area, and doesn't include any borders.

Returns:
the size of the client area of the Window.
See also:
Window::WindowSize

Point Window::CursorPosition ( ) const

Returns the position of the cursor, relative to the Window.

Returns:
the position of the cursor, relative to the Window.

bool Window::Destroy ( ) [virtual]

Destroy the associated HWND.

If this Window is a contained within a Container this method will be called automatically.

Returns:
true if successful, false otherwise.
See also:
Container

bool Window::Enable ( bool enable )

Changes the enabled state of the Window.

Parameters:
enable whether or not the Window is enabled.
Returns:
true if successful, false otherwise.

FontRef Window::Font ( ) const

Returns a shared pointer to the Font the Window uses to draw its text.

Returns:
a shared pointer to the Font the Window uses to draw its text different controls.
See also:
Font, FontRef

HWND Window::Handle ( ) const

Returns the HWND that the Window wraps.

Returns:
the HWND that the Window wraps.
See also:
Window::SendMessage(), Window::PostMessage

void Window::Initialize ( Window * parent = NULL )

Used to force creation of a control. Although this can be called manually it's generally recommended to let Container controls automatically intialize their children.

Unless creating a TopLevelWindow, parent should always be non-NULL and initialized.

Exceptions:
WindowAlreadyCreatedException,WindowCreationFailedException
Parameters:
parent The Window's parent.

Point Window::Location ( ) const

Returns the location of the window, relative to its parent Window.

Returns:
the location of the window, relative to its parent Window.

MenuRef Window::Menu ( )

Returns the Window's Menu.

See also:
Menu, MenuRef, Window::SetMenu

bool Window::MoveTo ( const Point & location )

Moves the Window to the specified coordinates.

The coordinates specified are interpreted as relative to the control's parent window. Will emit the Window::Moved event if successful.

Parameters:
location location of the window, in pixels, relative to the parent
Returns:
true if succesful, false otherwise.

bool Window::MoveTo | ( | int | x,
 |  | int | y
 | ) |  |

Moves the Window to the specified coordinates.

The coordinates specified are interpreted as relative to the control's parent window. Will emit the Window::Moved event if successful.

Parameters:
x | location of the window, in pixels, relative to the parent
y | location of the window, in pixels, relative to the parent
Returns:
true if succesful, false otherwise.

Window * Window::Parent ( ) const

Returns a pointer to the Window's parent.

This method will throw a WindowNotCreatedException if the Window has not been created yet. It may also return NULL if the Window is created but currently has no parent.

Exceptions:
WindowNotCreatedException
Returns:
Write description of return value here.
Exceptions:
WindowNotCreatedException

bool Window::PostMessage | ( | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Asynchronously invokes a message on the Window.

See: http://msdn2.microsoft.com/en-us/library/ms644944.aspx

Parameters:
message | The message ID
wParam | The wParam value
lParam | The lParam value.
Returns:
Value varies based on the message. See MSDN for more information.
See also:
Window::SendMessage

void Window::Redraw ( ) const

Redraws the Window.

Internally this method calls InvalidateRect(Handle(), NULL, FALSE)

bool Window::Resize ( const Size & size )

Resizes the window to the specified size.

Parameters:
size size of the window, in pixels.
Returns:
true on success, false otherwise.

bool Window::Resize | ( | int | width,
 |  | int | height
 | ) |  |

Resizes the window to the specified size.

Parameters:
width | width of the window, in pixels.
height | height of the window, in pixels.
Returns:
true on success, false otherwise.

LRESULT Window::SendMessage | ( | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Synchronously invokes a message on the Window.

See: http://msdn2.microsoft.com/en-us/library/ms644950.aspx

Parameters:
message | The message ID
wParam | The wParam value
lParam | The lParam value.
Returns:
Value varies based on the message. See MSDN for more information.
See also:
Window::PostMessage

void Window::SetBackgroundColor ( const Color & color )

Sets the background color of the ListView.

Parameters:
color The color to use.
See also:
Window::BackgroundColor

bool Window::SetCaption ( const uistring & caption )

Sets the caption of the Window.

Internally this method uses Win32's SetWindowText

Parameters:
caption The desired Window caption.
Returns:
true if successful, false otherwise.

void Window::SetFont ( FontRef font )

Sets the Font the Window uses to draw its caption.

Parameters:
font A shared pointer to a Font object. A FontRef can be shared amongst different controls.
See also:
Font, FontRef

void Window::SetMenu ( MenuRef menu )

Sets the Window's Menu.

See also:
Menu, MenuRef, Window::Menu

bool Window::SetRectangle ( const Rect & rectangle )

Moves and resizes the Window to rectangle.location and rectangle.size.

Emits Window::Moved and Window::Resized. Note this method sets the WindowRect, and not the ClientRect. The ClientRect cannot be set explicitly.

Parameters:
rectangle Specifies the Window's new location and size.
Returns:
true if successful, false otherwise.
See also:
Window::MoveTo, Window::Resize, Window::WindowRect, Window::ClientRect

void Window::SetTabStop ( bool enabled )

Sets whether or not this control can be focused via Tab key.

Parameters:
enabled If true this control can be focused via the Tab key

void Window::SetVisible ( bool visible = true )

Shows or hides the window.

Parameters:
visible If true the window will be made visible, otherwise it will be hidden.
See also:
Windowd::Visible

bool Window::Show ( int showCommand )

Used to modify the visibility of a Window. Commonly used flags are SW_SHOW and SW_HIDE.

Parameters:
showCommand One of the flags listed here: http://msdn2.microsoft.com/en-us/library/ms633548.aspx
Returns:
true if the operation was successful, false otherwise..

bool Window::Visible ( )

Returns true if the window is visible.

See also:
Windowd::SetVisible

Rect Window::WindowRect ( ) const

Returns the Window's rectangle.

The Window::WindowRect is the bounding rectangle of the entire Window including borders. Not to be confused with Windodw::ClientRect.

Returns:
the Window's rectangle.
See also:
Window::ClientRect, Window::SetRectangle

Size Window::WindowSize ( ) const

Returns the size of the Window.

Not to be confused with Window::ClientSize, Window::WindowSize returns the size of the entire window, not just the content area.

Returns:
the size of the Window.
See also:
Window::ClientSize

Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Member List

win32cpp::Window Member List

This is the complete list of members for win32cpp::Window, including all inherited members.

BackgroundColor() const | win32cpp::Window |
Caption() const | win32cpp::Window |
Char | win32cpp::Window |
ClientRect() const | win32cpp::Window |
ClientSize() const | win32cpp::Window |
Created | win32cpp::Window |
CursorPosition() const | win32cpp::Window |
Destroy() | win32cpp::Window | [virtual]
Destroyed | win32cpp::Window |
Enable(bool enable) | win32cpp::Window |
Font() const | win32cpp::Window |
GainedFocus | win32cpp::Window |
Handle() const | win32cpp::Window |
Initialize(Window *parent=NULL) | win32cpp::Window |
KeyDown | win32cpp::Window |
KeyUp | win32cpp::Window |
Location() const | win32cpp::Window |
LostFocus | win32cpp::Window |
Menu() | win32cpp::Window |
MouseButtonDoubleClicked | win32cpp::Window |
MouseButtonDown | win32cpp::Window |
MouseButtonUp | win32cpp::Window |
MouseEnter | win32cpp::Window |
MouseExit | win32cpp::Window |
MouseMoved | win32cpp::Window |
Moved | win32cpp::Window |
MoveTo(int x, int y) | win32cpp::Window |
MoveTo(const Point &location) | win32cpp::Window |
Parent() const | win32cpp::Window |
ParentChanged | win32cpp::Window |
PostMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
Redraw() const | win32cpp::Window |
RequestFocusNext | win32cpp::Window |
RequestFocusPrev | win32cpp::Window |
Resize(int width, int height) | win32cpp::Window |
Resize(const Size &size) | win32cpp::Window |
Resized | win32cpp::Window |
SendMessage(UINT message, WPARAM wParam, LPARAM lParam) | win32cpp::Window |
SetBackgroundColor(const Color &color) | win32cpp::Window |
SetCaption(const uistring &caption) | win32cpp::Window |
SetFocus() | win32cpp::Window |
SetFont(FontRef font) | win32cpp::Window |
SetMenu(MenuRef menu) | win32cpp::Window |
SetRectangle(const Rect &rectangle) | win32cpp::Window |
SetTabStop(bool enabled) | win32cpp::Window |
SetVisible(bool visible=true) | win32cpp::Window |
Show(int showCommand) | win32cpp::Window |
TabStop() | win32cpp::Window |
ThemeChanged | win32cpp::Window |
TimerTimeout | win32cpp::Window |
VisibilityChanged | win32cpp::Window |
Visible() | win32cpp::Window |
WindowRect() const | win32cpp::Window |
WindowSize() const | win32cpp::Window |

Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: win32cpp::Window::WindowAlreadyCreatedException Class Reference

win32cpp::Window::WindowAlreadyCreatedException

win32cpp::Window::WindowAlreadyCreatedException Class Reference

This exception will be thrown if Initialize() is called on a Window that has already been created. More...

#include <Window.hpp>

Inheritance diagram for win32cpp::Window::WindowAlreadyCreatedException:

[legend]

List of all members.

Detailed Description

This exception will be thrown if Initialize() is called on a Window that has already been created.
Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Member List

win32cpp::Window::WindowAlreadyCreatedException Member List

This is the complete list of members for win32cpp::Window::WindowAlreadyCreatedException, including all inherited members.

Exception() | win32cpp::Exception |
Exception(const char *message) | win32cpp::Exception |
Message() | win32cpp::Exception | [virtual]

Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: win32cpp::Window::WindowCreationFailedException Class Reference

win32cpp::Window::WindowCreationFailedException

win32cpp::Window::WindowCreationFailedException Class Reference

This exception is thrown if a Window fails to be created. More...

#include <Window.hpp>

Inheritance diagram for win32cpp::Window::WindowCreationFailedException:

[legend]

List of all members.

Detailed Description

This exception is thrown if a Window fails to be created.
Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Member List

win32cpp::Window::WindowCreationFailedException Member List

This is the complete list of members for win32cpp::Window::WindowCreationFailedException, including all inherited members.

Exception() | win32cpp::Exception |
Exception(const char *message) | win32cpp::Exception |
Message() | win32cpp::Exception | [virtual]

Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: win32cpp::Window::WindowIsNullException Class Reference

win32cpp::Window::WindowIsNullException

win32cpp::Window::WindowIsNullException Class Reference

This exception is thrown if a Window parameter is NULL where it shouldn't be. More...

#include <Window.hpp>

Inheritance diagram for win32cpp::Window::WindowIsNullException:

[legend]

List of all members.

Detailed Description

This exception is thrown if a Window parameter is NULL where it shouldn't be.
Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Member List

win32cpp::Window::WindowIsNullException Member List

This is the complete list of members for win32cpp::Window::WindowIsNullException, including all inherited members.

Exception() | win32cpp::Exception |
Exception(const char *message) | win32cpp::Exception |
Message() | win32cpp::Exception | [virtual]

Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: win32cpp::Window::WindowNotCreatedException Class Reference

win32cpp::Window::WindowNotCreatedException

win32cpp::Window::WindowNotCreatedException Class Reference

This exception may be thrown if operations are attempted on a Window that has not been created. More...

#include <Window.hpp>

Inheritance diagram for win32cpp::Window::WindowNotCreatedException:

[legend]

List of all members.

Detailed Description

This exception may be thrown if operations are attempted on a Window that has not been created.
Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Member List

win32cpp::Window::WindowNotCreatedException Member List

This is the complete list of members for win32cpp::Window::WindowNotCreatedException, including all inherited members.

Exception() | win32cpp::Exception |
Exception(const char *message) | win32cpp::Exception |
Message() | win32cpp::Exception | [virtual]

Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • AddChild() : win32cpp::Container
  • AddColumn() : win32cpp::ListView
  • AddIcon() : win32cpp::SysTray
  • Alignment() : win32cpp::ListView::Column
  • Anchor() : win32cpp::Splitter
  • AnchorConstraints() : win32cpp::Splitter
  • ApplicationThread() : win32cpp::ApplicationThread
  • AutoResizeFromCaptionEnabled() : win32cpp::Label


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • KeyDown : win32cpp::Window
  • KeyUp : win32cpp::Window


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • Label() : win32cpp::Label
  • left : win32cpp::FramePadding
  • Lighten() : win32cpp::Color
  • LimitText() : win32cpp::EditView
  • LinearLayout() : win32cpp::LinearLayout
  • ListView() : win32cpp::ListView
  • location : win32cpp::Rect
  • Location() : win32cpp::Window
  • LostFocus : win32cpp::Window


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • MainWindow() : win32cpp::Application
  • MemoryDC() : win32cpp::MemoryDC
  • Menu() : win32cpp::Window
  • Message()
: win32cpp::Exception
, win32cpp::Win32Exception
  • MinimumSize() : win32cpp::TopLevelWindow
  • Model() : win32cpp::ListView::Model
  • ModelRef : win32cpp::ListView
  • MouseButtonDoubleClicked : win32cpp::Window
  • MouseButtonDown : win32cpp::Window
  • MouseButtonUp : win32cpp::Window
  • MouseEnter : win32cpp::Window
  • MouseExit : win32cpp::Window
  • MouseMoved : win32cpp::Window
  • Moved : win32cpp::Window
  • MoveTo() : win32cpp::Window
  • MultipleSelectionEnabled() : win32cpp::ListView


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • Name() : win32cpp::ListView::Column


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • operator COLORREF() : win32cpp::Color
  • operator HDC() : win32cpp::MemoryDC
  • operator HINSTANCE() : win32cpp::Application
  • operator POINT() : win32cpp::Point
  • operator RECT() : win32cpp::Rect
  • operator SIZE() : win32cpp::Size
  • operator!=() : win32cpp::FramePadding
  • operator==() : win32cpp::FramePadding


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~ApplicationThread() : win32cpp::ApplicationThread


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • BackgroundColor() : win32cpp::Window
  • BarLayout() : win32cpp::BarLayout
  • Bold() : win32cpp::Font
  • bottom : win32cpp::FramePadding
  • Button() : win32cpp::Button


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • Caption()
: win32cpp::RadioButton
, win32cpp::Window
  • CellAtPoint() : win32cpp::ListView
  • CellRenderer() : win32cpp::ListView::Model
  • CellRendererRef : win32cpp::ListView
  • CellValueToString() : win32cpp::ListView::Model
  • Char : win32cpp::Window
  • Checkbox() : win32cpp::Checkbox
  • Child1() : win32cpp::Splitter
  • Child2() : win32cpp::Splitter
  • ClientRect() : win32cpp::Window
  • ClientSize() : win32cpp::Window
  • Close() : win32cpp::TopLevelWindow
  • Color() : win32cpp::Color
  • Column() : win32cpp::ListView::Column
  • ColumnClicked : win32cpp::ListView
  • ColumnClickedEvent : win32cpp::ListView
  • ColumnRef : win32cpp::ListView
  • ColumnsVisible() : win32cpp::ListView
  • ColumnWidth() : win32cpp::ListView
  • CommandLine() : win32cpp::Application
  • Created : win32cpp::Window
  • CreateHFONT() : win32cpp::Font
  • CursorPosition() : win32cpp::Window


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • Darken() : win32cpp::Color
  • DataChanged : win32cpp::ListView::Model
  • DataChangedEvent : win32cpp::ListView::Model
  • DefaultWidth() : win32cpp::ListView::Column
  • DeleteIcon() : win32cpp::SysTray
  • Destroy() : win32cpp::Window
  • Destroyed : win32cpp::Window
  • DrawToHDC() : win32cpp::Font


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • EditView() : win32cpp::EditView
  • Enable() : win32cpp::Window
  • EnableAutoResizeFromCaption() : win32cpp::Label
  • EnableColumnResizing() : win32cpp::ListView
  • EnableMinimizeToTray() : win32cpp::SysTray
  • EnableMultipleSelection() : win32cpp::ListView
  • EnableStripedBackground() : win32cpp::ListView
  • Exception() : win32cpp::Exception


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • FaceName() : win32cpp::Font
  • Font() : win32cpp::Window
  • Frame() : win32cpp::Frame
  • FramePadding() : win32cpp::FramePadding


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GainedFocus : win32cpp::Window
  • GetHFONT() : win32cpp::Font


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • Handle() : win32cpp::Window
  • Height() : win32cpp::Rect
  • height : win32cpp::Size
  • HotCellChanged : win32cpp::ListView
  • HotCellChangedEvent : win32cpp::ListView
  • HotColumn() : win32cpp::ListView
  • HotRow() : win32cpp::ListView
  • HotRowChanged : win32cpp::ListView
  • HotRowChangedEvent : win32cpp::ListView


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • Initialize()
: win32cpp::Application
, win32cpp::Window
  • InMainThread() : win32cpp::ApplicationThread
  • Instance() : win32cpp::Application
  • IsSizable() : win32cpp::Splitter
  • Italic() : win32cpp::Font


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • Panel() : win32cpp::Panel
  • Parent() : win32cpp::Window
  • ParentChanged : win32cpp::Window
  • Point() : win32cpp::Point
  • PointSize() : win32cpp::Font
  • PostMessage() : win32cpp::Window
  • Pressed
: win32cpp::Checkbox
, win32cpp::RadioButton
, win32cpp::Button
  • PreviousInstance() : win32cpp::Application
  • ProgressBar() : win32cpp::ProgressBar


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • RadioButton() : win32cpp::RadioButton
  • Rect() : win32cpp::Rect
  • Redraw() : win32cpp::Window
  • RedrawCell() : win32cpp::ListView
  • RedrawLock() : win32cpp::RedrawLock
  • RedrawRow() : win32cpp::ListView
  • RemoveChild() : win32cpp::Container
  • RemoveColumn() : win32cpp::ListView
  • Render()
: win32cpp::ListView::RowRenderer
, win32cpp::ListView::CellRenderer
, win32cpp::ListView::TextCellRenderer< T >
  • Repositioned : win32cpp::Trackbar
  • RequestFocusNext : win32cpp::Window
  • RequestFocusPrev : win32cpp::Window
  • ResizableColumnsEnabled() : win32cpp::ListView
  • Resize() : win32cpp::Window
  • Resized : win32cpp::Window
  • ResizeFromCaption() : win32cpp::Label
  • right : win32cpp::FramePadding
  • RowActivated : win32cpp::ListView
  • RowActivatedEvent : win32cpp::ListView
  • RowAtPoint() : win32cpp::ListView
  • RowCount() : win32cpp::ListView::Model
  • RowCountChanged : win32cpp::ListView::Model
  • RowCountChangedEvent : win32cpp::ListView::Model
  • RowHeight() : win32cpp::ListView
  • RowIndexList : win32cpp::ListView
  • RowRenderer() : win32cpp::ListView::Model
  • RowRendererRef : win32cpp::ListView
  • Run() : win32cpp::Application


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • ScrollToRow() : win32cpp::ListView
  • SelectAll() : win32cpp::EditView
  • SelectedRow() : win32cpp::ListView
  • SelectedRows() : win32cpp::ListView
  • SelectionChanged : win32cpp::ListView
  • SelectionChangedEvent : win32cpp::ListView
  • SendMessage() : win32cpp::Window
  • SetAnchor() : win32cpp::Splitter
  • SetAnchorConstraints() : win32cpp::Splitter
  • SetAnchorSize() : win32cpp::Splitter
  • SetBackgroundColor() : win32cpp::Window
  • SetBold() : win32cpp::Font
  • SetCaption() : win32cpp::Window
  • SetChild1() : win32cpp::Splitter
  • SetChild2() : win32cpp::Splitter
  • SetChildAlignment() : win32cpp::LinearLayout
  • SetChildFill() : win32cpp::LinearLayout
  • SetColumnsVisible() : win32cpp::ListView
  • SetColumnWidth() : win32cpp::ListView
  • SetContextMenu() : win32cpp::ListView
  • SetDefaultChildAlignment() : win32cpp::LinearLayout
  • SetDefaultChildFill() : win32cpp::LinearLayout
  • SetFaceName() : win32cpp::Font
  • SetFlexibleChild() : win32cpp::LinearLayout
  • SetFocus() : win32cpp::Window
  • SetFont() : win32cpp::Window
  • SetGripperSize() : win32cpp::Splitter
  • SetIcon() : win32cpp::SysTray
  • SetItalic() : win32cpp::Font
  • SetMarqueeStyle() : win32cpp::ProgressBar
  • SetMenu() : win32cpp::Window
  • SetMinimumSize() : win32cpp::TopLevelWindow
  • SetModel() : win32cpp::ListView
  • SetPadding() : win32cpp::Frame
  • SetPointSize() : win32cpp::Font
  • SetPopupMenu() : win32cpp::SysTray
  • SetPos() : win32cpp::ProgressBar
  • SetRange() : win32cpp::ProgressBar
  • SetReadOnly() : win32cpp::EditView
  • SetRectangle() : win32cpp::Window
  • SetRowCount() : win32cpp::ListView::Model
  • SetRowHeight() : win32cpp::ListView
  • SetScrollBarVisibility() : win32cpp::ListView
  • SetSelection() : win32cpp::EditView
  • SetSizable() : win32cpp::Splitter
  • SetSmoothStyle() : win32cpp::ProgressBar
  • SetSpacing()
: win32cpp::BarLayout
, win32cpp::LinearLayout
  • SetStepIncrement() : win32cpp::ProgressBar
  • SetTabStop() : win32cpp::Window
  • SetTooltip()
: win32cpp::SysTray
, win32cpp::EditView
  • SetUnderline() : win32cpp::Font
  • SetVerticalStyle() : win32cpp::ProgressBar
  • SetVisible() : win32cpp::Window
  • SetWeight() : win32cpp::Font
  • Show() : win32cpp::Window
  • ShowBalloon() : win32cpp::SysTray
  • ShowCaret() : win32cpp::EditView
  • ShowCommand() : win32cpp::Application
  • Size() : win32cpp::Size
  • size : win32cpp::Rect
  • Size() : win32cpp::Size
  • Spacing()
: win32cpp::BarLayout
, win32cpp::LinearLayout
  • Splitter() : win32cpp::Splitter
  • StartMarquee() : win32cpp::ProgressBar
  • Step() : win32cpp::ProgressBar
  • StripedBackgroundEnabled() : win32cpp::ListView
  • SystemColor() : win32cpp::Color
  • SysTrayManager() : win32cpp::Application


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TabStop() : win32cpp::Window
  • TabView() : win32cpp::TabView
  • Terminate() : win32cpp::Application
  • TextCellRenderer() : win32cpp::ListView::TextCellRenderer< T >
  • ThemeChanged : win32cpp::Window
  • Thread() : win32cpp::Application
  • TimerTimeout : win32cpp::Window
  • top : win32cpp::FramePadding
  • TopLevelWindow() : win32cpp::TopLevelWindow


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • Underline() : win32cpp::Font
  • Undo() : win32cpp::EditView


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • VisibilityChanged : win32cpp::Window
  • Visible() : win32cpp::Window


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • Weight() : win32cpp::Font
  • Width() : win32cpp::Rect
  • width : win32cpp::Size
  • WindowProc() : win32cpp::SysTray
  • WindowRect() : win32cpp::Window
  • WindowSize() : win32cpp::Window


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • X() : win32cpp::Rect
  • x : win32cpp::Point


win32cpp: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • Y() : win32cpp::Rect
  • y : win32cpp::Point


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- a -

  • AddChild() : win32cpp::Container
  • AddColumn() : win32cpp::ListView
  • AddIcon() : win32cpp::SysTray
  • Alignment() : win32cpp::ListView::Column
  • Anchor() : win32cpp::Splitter
  • AnchorConstraints() : win32cpp::Splitter
  • ApplicationThread() : win32cpp::ApplicationThread
  • AutoResizeFromCaptionEnabled() : win32cpp::Label


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- l -

  • Label() : win32cpp::Label
  • Lighten() : win32cpp::Color
  • LimitText() : win32cpp::EditView
  • LinearLayout() : win32cpp::LinearLayout
  • ListView() : win32cpp::ListView
  • Location() : win32cpp::Window


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- m -

  • MainWindow() : win32cpp::Application
  • MemoryDC() : win32cpp::MemoryDC
  • Menu() : win32cpp::Window
  • Message()
: win32cpp::Exception
, win32cpp::Win32Exception
  • MinimumSize() : win32cpp::TopLevelWindow
  • Model() : win32cpp::ListView::Model
  • MoveTo() : win32cpp::Window
  • MultipleSelectionEnabled() : win32cpp::ListView


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- n -

  • Name() : win32cpp::ListView::Column


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- o -

  • operator COLORREF() : win32cpp::Color
  • operator HDC() : win32cpp::MemoryDC
  • operator HINSTANCE() : win32cpp::Application
  • operator POINT() : win32cpp::Point
  • operator RECT() : win32cpp::Rect
  • operator SIZE() : win32cpp::Size
  • operator!=() : win32cpp::FramePadding
  • operator==() : win32cpp::FramePadding


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- ~ -

  • ~ApplicationThread() : win32cpp::ApplicationThread


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- b -

  • BackgroundColor() : win32cpp::Window
  • BarLayout() : win32cpp::BarLayout
  • Bold() : win32cpp::Font
  • Button() : win32cpp::Button


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- c -

  • Caption()
: win32cpp::RadioButton
, win32cpp::Window
  • CellAtPoint() : win32cpp::ListView
  • CellRenderer() : win32cpp::ListView::Model
  • CellValueToString() : win32cpp::ListView::Model
  • Checkbox() : win32cpp::Checkbox
  • Child1() : win32cpp::Splitter
  • Child2() : win32cpp::Splitter
  • ClientRect() : win32cpp::Window
  • ClientSize() : win32cpp::Window
  • Close() : win32cpp::TopLevelWindow
  • Color() : win32cpp::Color
  • Column() : win32cpp::ListView::Column
  • ColumnsVisible() : win32cpp::ListView
  • ColumnWidth() : win32cpp::ListView
  • CommandLine() : win32cpp::Application
  • CreateHFONT() : win32cpp::Font
  • CursorPosition() : win32cpp::Window


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- d -

  • Darken() : win32cpp::Color
  • DefaultWidth() : win32cpp::ListView::Column
  • DeleteIcon() : win32cpp::SysTray
  • Destroy() : win32cpp::Window
  • DrawToHDC() : win32cpp::Font


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- e -

  • EditView() : win32cpp::EditView
  • Enable() : win32cpp::Window
  • EnableAutoResizeFromCaption() : win32cpp::Label
  • EnableColumnResizing() : win32cpp::ListView
  • EnableMinimizeToTray() : win32cpp::SysTray
  • EnableMultipleSelection() : win32cpp::ListView
  • EnableStripedBackground() : win32cpp::ListView
  • Exception() : win32cpp::Exception


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- f -

  • FaceName() : win32cpp::Font
  • Font() : win32cpp::Window
  • Frame() : win32cpp::Frame
  • FramePadding() : win32cpp::FramePadding


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- g -

  • GetHFONT() : win32cpp::Font


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- h -

  • Handle() : win32cpp::Window
  • Height() : win32cpp::Rect
  • HotColumn() : win32cpp::ListView
  • HotRow() : win32cpp::ListView


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- i -

  • Initialize()
: win32cpp::Application
, win32cpp::Window
  • InMainThread() : win32cpp::ApplicationThread
  • Instance() : win32cpp::Application
  • IsSizable() : win32cpp::Splitter
  • Italic() : win32cpp::Font


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- p -

  • Panel() : win32cpp::Panel
  • Parent() : win32cpp::Window
  • Point() : win32cpp::Point
  • PointSize() : win32cpp::Font
  • PostMessage() : win32cpp::Window
  • PreviousInstance() : win32cpp::Application
  • ProgressBar() : win32cpp::ProgressBar


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- r -

  • RadioButton() : win32cpp::RadioButton
  • Rect() : win32cpp::Rect
  • Redraw() : win32cpp::Window
  • RedrawCell() : win32cpp::ListView
  • RedrawLock() : win32cpp::RedrawLock
  • RedrawRow() : win32cpp::ListView
  • RemoveChild() : win32cpp::Container
  • RemoveColumn() : win32cpp::ListView
  • Render()
: win32cpp::ListView::RowRenderer
, win32cpp::ListView::CellRenderer
, win32cpp::ListView::TextCellRenderer< T >
  • ResizableColumnsEnabled() : win32cpp::ListView
  • Resize() : win32cpp::Window
  • ResizeFromCaption() : win32cpp::Label
  • RowAtPoint() : win32cpp::ListView
  • RowCount() : win32cpp::ListView::Model
  • RowHeight() : win32cpp::ListView
  • RowRenderer() : win32cpp::ListView::Model
  • Run() : win32cpp::Application


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- s -

  • ScrollToRow() : win32cpp::ListView
  • SelectAll() : win32cpp::EditView
  • SelectedRow() : win32cpp::ListView
  • SelectedRows() : win32cpp::ListView
  • SendMessage() : win32cpp::Window
  • SetAnchor() : win32cpp::Splitter
  • SetAnchorConstraints() : win32cpp::Splitter
  • SetAnchorSize() : win32cpp::Splitter
  • SetBackgroundColor() : win32cpp::Window
  • SetBold() : win32cpp::Font
  • SetCaption() : win32cpp::Window
  • SetChild1() : win32cpp::Splitter
  • SetChild2() : win32cpp::Splitter
  • SetChildAlignment() : win32cpp::LinearLayout
  • SetChildFill() : win32cpp::LinearLayout
  • SetColumnsVisible() : win32cpp::ListView
  • SetColumnWidth() : win32cpp::ListView
  • SetContextMenu() : win32cpp::ListView
  • SetDefaultChildAlignment() : win32cpp::LinearLayout
  • SetDefaultChildFill() : win32cpp::LinearLayout
  • SetFaceName() : win32cpp::Font
  • SetFlexibleChild() : win32cpp::LinearLayout
  • SetFocus() : win32cpp::Window
  • SetFont() : win32cpp::Window
  • SetGripperSize() : win32cpp::Splitter
  • SetIcon() : win32cpp::SysTray
  • SetItalic() : win32cpp::Font
  • SetMarqueeStyle() : win32cpp::ProgressBar
  • SetMenu() : win32cpp::Window
  • SetMinimumSize() : win32cpp::TopLevelWindow
  • SetModel() : win32cpp::ListView
  • SetPadding() : win32cpp::Frame
  • SetPointSize() : win32cpp::Font
  • SetPopupMenu() : win32cpp::SysTray
  • SetPos() : win32cpp::ProgressBar
  • SetRange() : win32cpp::ProgressBar
  • SetReadOnly() : win32cpp::EditView
  • SetRectangle() : win32cpp::Window
  • SetRowCount() : win32cpp::ListView::Model
  • SetRowHeight() : win32cpp::ListView
  • SetScrollBarVisibility() : win32cpp::ListView
  • SetSelection() : win32cpp::EditView
  • SetSizable() : win32cpp::Splitter
  • SetSmoothStyle() : win32cpp::ProgressBar
  • SetSpacing()
: win32cpp::BarLayout
, win32cpp::LinearLayout
  • SetStepIncrement() : win32cpp::ProgressBar
  • SetTabStop() : win32cpp::Window
  • SetTooltip()
: win32cpp::EditView
, win32cpp::SysTray
  • SetUnderline() : win32cpp::Font
  • SetVerticalStyle() : win32cpp::ProgressBar
  • SetVisible() : win32cpp::Window
  • SetWeight() : win32cpp::Font
  • Show() : win32cpp::Window
  • ShowBalloon() : win32cpp::SysTray
  • ShowCaret() : win32cpp::EditView
  • ShowCommand() : win32cpp::Application
  • Size() : win32cpp::Size
  • Spacing()
: win32cpp::LinearLayout
, win32cpp::BarLayout
  • Splitter() : win32cpp::Splitter
  • StartMarquee() : win32cpp::ProgressBar
  • Step() : win32cpp::ProgressBar
  • StripedBackgroundEnabled() : win32cpp::ListView
  • SystemColor() : win32cpp::Color
  • SysTrayManager() : win32cpp::Application


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- t -

  • TabStop() : win32cpp::Window
  • TabView() : win32cpp::TabView
  • Terminate() : win32cpp::Application
  • TextCellRenderer() : win32cpp::ListView::TextCellRenderer< T >
  • Thread() : win32cpp::Application
  • TopLevelWindow() : win32cpp::TopLevelWindow


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- u -

  • Underline() : win32cpp::Font
  • Undo() : win32cpp::EditView


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- v -

  • Visible() : win32cpp::Window


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- w -

  • Weight() : win32cpp::Font
  • Width() : win32cpp::Rect
  • WindowProc() : win32cpp::SysTray
  • WindowRect() : win32cpp::Window
  • WindowSize() : win32cpp::Window


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- x -

  • X() : win32cpp::Rect


win32cpp: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- y -

  • Y() : win32cpp::Rect


win32cpp: Class Members - Typedefs

  • All
  • Functions
  • Variables
  • Typedefs

  • CellRendererRef : win32cpp::ListView
  • ColumnClickedEvent : win32cpp::ListView
  • ColumnRef : win32cpp::ListView
  • DataChangedEvent : win32cpp::ListView::Model
  • HotCellChangedEvent : win32cpp::ListView
  • HotRowChangedEvent : win32cpp::ListView
  • ModelRef : win32cpp::ListView
  • RowActivatedEvent : win32cpp::ListView
  • RowCountChangedEvent : win32cpp::ListView::Model
  • RowIndexList : win32cpp::ListView
  • RowRendererRef : win32cpp::ListView
  • SelectionChangedEvent : win32cpp::ListView


win32cpp: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • b
  • c
  • d
  • g
  • h
  • k
  • l
  • m
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y

- b -

  • bottom : win32cpp::FramePadding

- c -

  • Char : win32cpp::Window
  • ColumnClicked : win32cpp::ListView
  • Created : win32cpp::Window

- d -

  • DataChanged : win32cpp::ListView::Model
  • Destroyed : win32cpp::Window

- g -

  • GainedFocus : win32cpp::Window

- h -

  • height : win32cpp::Size
  • HotCellChanged : win32cpp::ListView
  • HotRowChanged : win32cpp::ListView

- k -

  • KeyDown : win32cpp::Window
  • KeyUp : win32cpp::Window

- l -

  • left : win32cpp::FramePadding
  • location : win32cpp::Rect
  • LostFocus : win32cpp::Window

- m -

  • MouseButtonDoubleClicked : win32cpp::Window
  • MouseButtonDown : win32cpp::Window
  • MouseButtonUp : win32cpp::Window
  • MouseEnter : win32cpp::Window
  • MouseExit : win32cpp::Window
  • MouseMoved : win32cpp::Window
  • Moved : win32cpp::Window

- p -

  • ParentChanged : win32cpp::Window
  • Pressed
: win32cpp::RadioButton
, win32cpp::Checkbox
, win32cpp::Button

- r -

  • Repositioned : win32cpp::Trackbar
  • RequestFocusNext : win32cpp::Window
  • RequestFocusPrev : win32cpp::Window
  • Resized : win32cpp::Window
  • right : win32cpp::FramePadding
  • RowActivated : win32cpp::ListView
  • RowCountChanged : win32cpp::ListView::Model

- s -

  • SelectionChanged : win32cpp::ListView
  • size : win32cpp::Rect

- t -

  • ThemeChanged : win32cpp::Window
  • TimerTimeout : win32cpp::Window
  • top : win32cpp::FramePadding

- v -

  • VisibilityChanged : win32cpp::Window

- w -

  • width : win32cpp::Size

- x -

  • x : win32cpp::Point

- y -

  • y : win32cpp::Point


win32cpp: Graphical Class Hierarchy

Graphical Class Hierarchy

Go to the textual class hierarchy


win32cpp: win32cpp Namespace Reference

  • Namespace List
  • Namespace Members

win32cpp Namespace Reference

namespace root More...

Classes

class | Application
Application is a singleton that provides basic information about the current process. More...
class | ApplicationThread
ApplicationThread is a class handling intercommunication to main thread. More...
class | BarLayout
TODO: document me. More...
class | Button
A standard push-button. The Button::Pressed event is emitted when the user activates the button. More...
class | Checkbox
A standard Checkbox. More...
struct | Color
An RGBA color. This class can be implicitly casted to and from Win32 COLORREF objects. More...
class | Container
Container is a specialization of Window that can house one or more child controls. More...
class | EditView
A standard edit control. More...
class | Exception
The base class for all exceptions thrown by win32cpp. More...
struct | Font
Font provides a light-weight wrapper around a Win32 HFONT object. More...
class | Frame
Frame is a Container that adds a padding (border) to a single child Window. More...
struct | FramePadding
FramePadding is used by Frame to specify the padding around the child control. More...
class | Label
A simple Window that draws only a caption. More...
class | LinearLayout
A Container that is used to stack controls horizontally or vertically. More...
class | ListView
A ListView is used for displaying data in row/column format. More...
class | MemoryDC
A memory device context. MemoryDC is used internally by various classes, including Window, for flicker free drawing. More...
class | NotImplementedException
Thrown when a method is not yet implemented. More...
class | Panel
Panel is the most basic concrete implementation of Container. More...
struct | Point
Represents a point. More...
class | ProgressBar
A progress bar. More...
class | RadioButton
A standard RadioButton. They are organised as linked list to enforce the grouping behaviour. More...
struct | Rect
Represents a rectangle. More...
struct | RedrawLock
Use RedrawLock to stop the specified Window from being redrawn. Redrawing is automatically enabled on the Window when the RedrawLock's destructor is called. More...
struct | Size
Represents a size. More...
class | Splitter
A Container with two children that can be resized with the mouse. More...
class | SysTray
The SysTray class is used for managing icons in the Taskbar. It must be seen as pure manager for the icons in the SysTray bar. Thus there are no special classes for TrayIcons. More...
class | TabView
Panel is the most basic concrete implementation of Container. More...
class | TopLevelWindow
A TopLevelWindow is a Window with a title bar, menu, and minimize, maximize, close boxes,. More...
class | Trackbar
Trackbar allows the user to select a value from a range. More...
class | Win32Exception
An Exception that represents an Win32 error. More...
class | Window
Window is the abstract base class for all controls. More...

Typedefs

typedef sigslot::signal1
< Button * > 		ButtonPressedEvent
The type of event used when a Button is pressed..
typedef unsigned char | byte
An unsigned byte.
typedef sigslot::signal2
< Checkbox *, int > 		CheckboxPressedEvent
The type of event used when the Checkbox is pressed..
typedef sigslot::signal1
< Window * > 		CreatedEvent
typedef sigslot::signal1
< Window * > 		DestroyedEvent
typedef sigslot::signal1
< EditView * > 		EditViewChangedEvent
The type of event used when a the edit control is changed.
typedef sigslot::has_slots | EventHandler
Classes wishing to handle sigslot signals must inherit from this class.
typedef sigslot::signal1
< Window * > 		FocusEvent
typedef boost::shared_ptr< Font > | FontRef
A shared pointer to a Font object.
typedef sigslot::signal3
< Window *, VirtualKeyCode,
KeyEventFlags > 		KeyEvent
typedef DWORD | KeyEventFlags
typedef sigslot::signal3
< Window *, MouseEventFlags,
Point > 		MouseButtonEvent
typedef sigslot::signal1
< Window * > 		MouseEnterEvent
typedef sigslot::signal1
< Window * > 		MouseExitEvent
typedef sigslot::signal3
< Window *, MouseEventFlags,
Point > 		MouseMovedEvent
typedef sigslot::signal2
< Window *, Point > 		MovedEvent
typedef sigslot::signal2
< Window *, Window * > 		ParentChangedEvent
typedef sigslot::signal1
< RadioButton * > 		RadioButtonPressedEvent
The type of event used when the Checkbox is pressed.
typedef sigslot::signal2
< Window *, Size > 		ResizedEvent
typedef sigslot::signal1
< Window * > 		ThemeChangedEvent
typedef sigslot::signal1
< unsigned int > 		TimerEvent
typedef sigslot::signal1
< Trackbar * > 		TrackbarRepositionedEvent
Event used when position on trackbar is changed.
typedef TCHAR | uichar
A single character, as used in the UI (a TCHAR).
typedef std::basic_string< uichar > | uistring
A std::basic_string<TCHAR>.
typedef DWORD | VirtualKeyCode
typedef sigslot::signal2
< Window *, bool > 		VisibilityChangedEvent

Enumerations

enum | AnchorDirection { AnchorTop, AnchorBottom, AnchorLeft, AnchorRight }
enum | BarLayoutOrientation { BarRowLayout, BarColumnLayout }
Specifies the orientation of a LinearLayout. More...
enum ChildAlignment {
ChildAlignLeft = 0, ChildAlignRight = 1, ChildAlignCenter = 2, ChildAlignTop = 0,
ChildAlignBottom = 1, ChildAlignMiddle = 2
}
Specifies the alignment of a Layout's child. More...
enum | LinearLayoutOrientation { LinearRowLayout, LinearColumnLayout }
Specifies the orientation of a LinearLayout. More...
enum MouseEventFlags {
MouseShiftKey = MK_SHIFT, MouseCtrlKey = MK_CONTROL, MouseLeftButton = MK_LBUTTON, MouseMiddleButton = MK_MBUTTON,
MouseRightButton = MK_RBUTTON, MouseX1Button = MK_XBUTTON1, MouseX2Button = MK_XBUTTON2
}
Flags used for mouse related events emitted by Window. More...
enum | ScrollBar { HorizontalScrollBar = SB_HORZ, VerticalScrollBar = SB_VERT, BothScrollBars = SB_BOTH }
ScrollBar is an enumeration that describles the orientation of a scrollbar. More...
enum | SplitDirection { SplitRow, SplitColumn }
enum | TextAlignment { TextAlignLeft = DT_LEFT, TextAlignCenter = DT_CENTER, TextAlignRight = DT_RIGHT }
TextAlignment specifies how text should be aligned when rendered. More...
enum | TrackbarOrientation { VerticalTrack = TBS_VERT, HorizontalTrack = TBS_HORZ }

Variables

const int | DefaultRowHeight = -1
Defines the a ListView's default row height.
const int | DisableConstraint = -1
Used to disable anchor constraints in Splitter.

Detailed Description

namespace root

Typedef Documentation

typedef sigslot::signal1<Button*> win32cpp::ButtonPressedEvent

The type of event used when a Button is pressed..

See also:
Button.

typedef sigslot::signal2<Checkbox*, int> win32cpp::CheckboxPressedEvent

The type of event used when the Checkbox is pressed..

See also:
CheckBox.

typedef sigslot::signal1<EditView*> win32cpp::EditViewChangedEvent

The type of event used when a the edit control is changed.

See also:
Button.

typedef sigslot::signal1<RadioButton*> win32cpp::RadioButtonPressedEvent

The type of event used when the Checkbox is pressed.

See also:
RadioButton.

typedef sigslot::signal1<Trackbar*> win32cpp::TrackbarRepositionedEvent

Event used when position on trackbar is changed.

See also:
Trackbar

typedef DWORD win32cpp::VirtualKeyCode

typedef DWORD win32cpp::KeyEventFlags

typedef sigslot::signal1<Window*> win32cpp::DestroyedEvent

typedef sigslot::signal1<Window*> win32cpp::CreatedEvent

typedef sigslot::signal2<Window*, Point> win32cpp::MovedEvent

typedef sigslot::signal2<Window*, Size> win32cpp::ResizedEvent

typedef sigslot::signal1<Window*> win32cpp::MouseEnterEvent

typedef sigslot::signal1<Window*> win32cpp::MouseExitEvent

typedef sigslot::signal3<Window*, MouseEventFlags, Point> win32cpp::MouseMovedEvent

typedef sigslot::signal3<Window*, MouseEventFlags, Point> win32cpp::MouseButtonEvent

typedef sigslot::signal1<Window*> win32cpp::ThemeChangedEvent

typedef sigslot::signal1<Window* > win32cpp::FocusEvent

typedef sigslot::signal2<Window* , Window* > win32cpp::ParentChangedEvent

typedef sigslot::signal1<unsigned int> win32cpp::TimerEvent

typedef sigslot::signal3<Window*, VirtualKeyCode, KeyEventFlags> win32cpp::KeyEvent

typedef sigslot::signal2<Window*, bool> win32cpp::VisibilityChangedEvent

Enumeration Type Documentation

enum win32cpp::BarLayoutOrientation

Specifies the orientation of a LinearLayout.

Enumerator:
BarRowLayout
BarColumnLayout

enum win32cpp::TextAlignment

TextAlignment specifies how text should be aligned when rendered.

See also:
Font::DrawToHDC
Enumerator:
TextAlignLeft
TextAlignCenter
TextAlignRight

enum win32cpp::ChildAlignment

Specifies the alignment of a Layout's child.

Enumerator:
ChildAlignLeft
ChildAlignRight
ChildAlignCenter
ChildAlignTop
ChildAlignBottom
ChildAlignMiddle

enum win32cpp::LinearLayoutOrientation

Specifies the orientation of a LinearLayout.

Enumerator:
LinearRowLayout
LinearColumnLayout

enum win32cpp::ScrollBar

ScrollBar is an enumeration that describles the orientation of a scrollbar.

Enumerator:
HorizontalScrollBar
VerticalScrollBar
BothScrollBars

enum win32cpp::SplitDirection

Enumerator:
SplitRow
SplitColumn

enum win32cpp::AnchorDirection

Enumerator:
AnchorTop
AnchorBottom
AnchorLeft
AnchorRight

enum win32cpp::TrackbarOrientation

Enumerator:
VerticalTrack
HorizontalTrack

enum win32cpp::MouseEventFlags

Flags used for mouse related events emitted by Window.

Enumerator:
MouseShiftKey
MouseCtrlKey
MouseLeftButton
MouseMiddleButton
MouseRightButton
MouseX1Button
MouseX2Button

Variable Documentation

const int win32cpp::DefaultRowHeight = -1

Defines the a ListView's default row height.

See also:
ListView::RowHeight, ListView::SetRowHeight

const int win32cpp::DisableConstraint = -1

Used to disable anchor constraints in Splitter.

See also:
Splitter::SetAnchorConstraints


win32cpp: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • k
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
Here is a list of all documented namespace members with links to the namespaces they belong to:

- a -

  • AnchorBottom : win32cpp
  • AnchorDirection : win32cpp
  • AnchorLeft : win32cpp
  • AnchorRight : win32cpp
  • AnchorTop : win32cpp

- b -

  • BarColumnLayout : win32cpp
  • BarLayoutOrientation : win32cpp
  • BarRowLayout : win32cpp
  • BothScrollBars : win32cpp
  • ButtonPressedEvent : win32cpp
  • byte : win32cpp

- c -

  • CheckboxPressedEvent : win32cpp
  • ChildAlignBottom : win32cpp
  • ChildAlignCenter : win32cpp
  • ChildAlignLeft : win32cpp
  • ChildAlignment : win32cpp
  • ChildAlignMiddle : win32cpp
  • ChildAlignRight : win32cpp
  • ChildAlignTop : win32cpp
  • CreatedEvent : win32cpp

- d -

  • DefaultRowHeight : win32cpp
  • DestroyedEvent : win32cpp
  • DisableConstraint : win32cpp

- e -

  • EditViewChangedEvent : win32cpp
  • EventHandler : win32cpp

- f -

  • FocusEvent : win32cpp
  • FontRef : win32cpp

- h -

  • HorizontalScrollBar : win32cpp
  • HorizontalTrack : win32cpp

- k -

  • KeyEvent : win32cpp
  • KeyEventFlags : win32cpp

- l -

  • LinearColumnLayout : win32cpp
  • LinearLayoutOrientation : win32cpp
  • LinearRowLayout : win32cpp

- m -

  • MouseButtonEvent : win32cpp
  • MouseCtrlKey : win32cpp
  • MouseEnterEvent : win32cpp
  • MouseEventFlags : win32cpp
  • MouseExitEvent : win32cpp
  • MouseLeftButton : win32cpp
  • MouseMiddleButton : win32cpp
  • MouseMovedEvent : win32cpp
  • MouseRightButton : win32cpp
  • MouseShiftKey : win32cpp
  • MouseX1Button : win32cpp
  • MouseX2Button : win32cpp
  • MovedEvent : win32cpp

- p -

  • ParentChangedEvent : win32cpp

- r -

  • RadioButtonPressedEvent : win32cpp
  • ResizedEvent : win32cpp

- s -

  • ScrollBar : win32cpp
  • SplitColumn : win32cpp
  • SplitDirection : win32cpp
  • SplitRow : win32cpp

- t -

  • TextAlignCenter : win32cpp
  • TextAlignLeft : win32cpp
  • TextAlignment : win32cpp
  • TextAlignRight : win32cpp
  • ThemeChangedEvent : win32cpp
  • TimerEvent : win32cpp
  • TrackbarOrientation : win32cpp
  • TrackbarRepositionedEvent : win32cpp

- u -

  • uichar : win32cpp
  • uistring : win32cpp

- v -

  • VerticalScrollBar : win32cpp
  • VerticalTrack : win32cpp
  • VirtualKeyCode : win32cpp
  • VisibilityChangedEvent : win32cpp
Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator

  • AnchorDirection : win32cpp
  • BarLayoutOrientation : win32cpp
  • ChildAlignment : win32cpp
  • LinearLayoutOrientation : win32cpp
  • MouseEventFlags : win32cpp
  • ScrollBar : win32cpp
  • SplitDirection : win32cpp
  • TextAlignment : win32cpp
  • TrackbarOrientation : win32cpp
Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • h
  • l
  • m
  • s
  • t
  • v

- a -

  • AnchorBottom : win32cpp
  • AnchorLeft : win32cpp
  • AnchorRight : win32cpp
  • AnchorTop : win32cpp

- b -

  • BarColumnLayout : win32cpp
  • BarRowLayout : win32cpp
  • BothScrollBars : win32cpp

- c -

  • ChildAlignBottom : win32cpp
  • ChildAlignCenter : win32cpp
  • ChildAlignLeft : win32cpp
  • ChildAlignMiddle : win32cpp
  • ChildAlignRight : win32cpp
  • ChildAlignTop : win32cpp

- h -

  • HorizontalScrollBar : win32cpp
  • HorizontalTrack : win32cpp

- l -

  • LinearColumnLayout : win32cpp
  • LinearRowLayout : win32cpp

- m -

  • MouseCtrlKey : win32cpp
  • MouseLeftButton : win32cpp
  • MouseMiddleButton : win32cpp
  • MouseRightButton : win32cpp
  • MouseShiftKey : win32cpp
  • MouseX1Button : win32cpp
  • MouseX2Button : win32cpp

- s -

  • SplitColumn : win32cpp
  • SplitRow : win32cpp

- t -

  • TextAlignCenter : win32cpp
  • TextAlignLeft : win32cpp
  • TextAlignRight : win32cpp

- v -

  • VerticalScrollBar : win32cpp
  • VerticalTrack : win32cpp
Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator

  • ButtonPressedEvent : win32cpp
  • byte : win32cpp
  • CheckboxPressedEvent : win32cpp
  • CreatedEvent : win32cpp
  • DestroyedEvent : win32cpp
  • EditViewChangedEvent : win32cpp
  • EventHandler : win32cpp
  • FocusEvent : win32cpp
  • FontRef : win32cpp
  • KeyEvent : win32cpp
  • KeyEventFlags : win32cpp
  • MouseButtonEvent : win32cpp
  • MouseEnterEvent : win32cpp
  • MouseExitEvent : win32cpp
  • MouseMovedEvent : win32cpp
  • MovedEvent : win32cpp
  • ParentChangedEvent : win32cpp
  • RadioButtonPressedEvent : win32cpp
  • ResizedEvent : win32cpp
  • ThemeChangedEvent : win32cpp
  • TimerEvent : win32cpp
  • TrackbarRepositionedEvent : win32cpp
  • uichar : win32cpp
  • uistring : win32cpp
  • VirtualKeyCode : win32cpp
  • VisibilityChangedEvent : win32cpp
Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator

  • DefaultRowHeight : win32cpp
  • DisableConstraint : win32cpp
Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Class List

Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
win32cpp::Application | Application is a singleton that provides basic information about the current process
win32cpp::Application::ApplicationAlreadyInitializedException | Thrown if Application::Initialize() is called more than once
win32cpp::Application::ApplicationAlreadyRunningException | Thrown if Application::Run() is called while the application is already running
win32cpp::ApplicationThread | ApplicationThread is a class handling intercommunication to main thread
win32cpp::BarLayout | TODO: document me
win32cpp::Button | A standard push-button. The Button::Pressed event is emitted when the user activates the button
win32cpp::Checkbox | A standard Checkbox
win32cpp::Color | An RGBA color. This class can be implicitly casted to and from Win32 COLORREF objects
win32cpp::Container | Container is a specialization of Window that can house one or more child controls
win32cpp::EditView | A standard edit control
win32cpp::Exception | The base class for all exceptions thrown by win32cpp
win32cpp::Font | Font provides a light-weight wrapper around a Win32 HFONT object
win32cpp::Frame | Frame is a Container that adds a padding (border) to a single child Window
win32cpp::FramePadding | FramePadding is used by Frame to specify the padding around the child control
win32cpp::Label | A simple Window that draws only a caption
win32cpp::LinearLayout | A Container that is used to stack controls horizontally or vertically
win32cpp::ListView | A ListView is used for displaying data in row/column format
win32cpp::ListView::CellRenderer | Used for rendering a (rowIndex, Column) pair
win32cpp::ListView::Column | Represents a Column of data in a ListView
win32cpp::ListView::InvalidColumnException |
win32cpp::ListView::InvalidSelectionTypeException |
win32cpp::ListView::Model | Supplies one or more ListView instances with data to display
win32cpp::ListView::RowRenderer | Used for rendering rows in the ListView
win32cpp::ListView::TextCellRenderer< T > | The default CellRenderer
win32cpp::MemoryDC | A memory device context. MemoryDC is used internally by various classes, including Window, for flicker free drawing
win32cpp::NotImplementedException | Thrown when a method is not yet implemented
win32cpp::Panel | Panel is the most basic concrete implementation of Container
win32cpp::Point | Represents a point
win32cpp::ProgressBar | A progress bar
win32cpp::RadioButton | A standard RadioButton. They are organised as linked list to enforce the grouping behaviour
win32cpp::Rect | Represents a rectangle
win32cpp::RedrawLock | Use RedrawLock to stop the specified Window from being redrawn. Redrawing is automatically enabled on the Window when the RedrawLock's destructor is called
win32cpp::Size | Represents a size
win32cpp::Splitter | A Container with two children that can be resized with the mouse
win32cpp::SysTray | Used for managing icons in the Taskbar. It must be seen as pure manager for the icons in the SysTray bar. Thus there are no special classes for TrayIcons
win32cpp::TabView | Panel is the most basic concrete implementation of Container
win32cpp::TopLevelWindow | A TopLevelWindow is a Window with a title bar, menu, and minimize, maximize, close boxes,
win32cpp::Trackbar | Trackbar allows the user to select a value from a range
win32cpp::Win32Exception | An Exception that represents an Win32 error
win32cpp::Window | Window is the abstract base class for all controls
win32cpp::Window::WindowAlreadyCreatedException | This exception will be thrown if Initialize() is called on a Window that has already been created
win32cpp::Window::WindowCreationFailedException | This exception is thrown if a Window fails to be created
win32cpp::Window::WindowIsNullException | This exception is thrown if a Window parameter is NULL where it shouldn't be
win32cpp::Window::WindowNotCreatedException | This exception may be thrown if operations are attempted on a Window that has not been created


win32cpp: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 240 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Wed Sep 3 17:44:08 2008 for win32cpp by doxygen 1.5.6


win32cpp: Hierarchical Index

Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:

  • win32cpp::Application
  • win32cpp::ApplicationThread
  • win32cpp::Color
  • win32cpp::Exception
    • win32cpp::Application::ApplicationAlreadyInitializedException
    • win32cpp::Application::ApplicationAlreadyRunningException
    • win32cpp::ListView::InvalidColumnException
    • win32cpp::ListView::InvalidSelectionTypeException
    • win32cpp::NotImplementedException
    • win32cpp::Win32Exception
    • win32cpp::Window::WindowAlreadyCreatedException
    • win32cpp::Window::WindowCreationFailedException
    • win32cpp::Window::WindowIsNullException
    • win32cpp::Window::WindowNotCreatedException
  • win32cpp::Font
  • win32cpp::FramePadding
  • win32cpp::ListView::CellRenderer
    • win32cpp::ListView::TextCellRenderer< T >
  • win32cpp::ListView::Column
  • win32cpp::ListView::Model
  • win32cpp::ListView::RowRenderer
  • win32cpp::MemoryDC
  • win32cpp::Point
  • win32cpp::Rect
  • win32cpp::RedrawLock
  • win32cpp::Size
  • win32cpp::SysTray
  • win32cpp::Window
    • win32cpp::Button
    • win32cpp::Checkbox
    • win32cpp::Container
      • win32cpp::Panel
        • win32cpp::BarLayout
        • win32cpp::Frame
        • win32cpp::LinearLayout
        • win32cpp::Splitter
      • win32cpp::TabView
      • win32cpp::TopLevelWindow
    • win32cpp::EditView
    • win32cpp::Label
    • win32cpp::ListView
    • win32cpp::ProgressBar
    • win32cpp::RadioButton
    • win32cpp::Trackbar


win32cpp: Main Page

win32cpp Documentation

Generated on Wed Sep 3 17:44:07 2008 for win32cpp by doxygen 1.5.6


win32cpp: Namespace Index

  • Namespace List
  • Namespace Members

Namespace List

Here is a list of all documented namespaces with brief descriptions:
win32cpp Namespace root