39 lines
561 B
Nix
39 lines
561 B
Nix
{ config, pkgs, ... }:
|
|
|
|
{
|
|
environment.systemPackages = with pkgs; [
|
|
exa
|
|
wget
|
|
htop
|
|
git
|
|
(import ./vim.nix)
|
|
neovim
|
|
nix-index
|
|
python2
|
|
python3
|
|
usbutils
|
|
pciutils
|
|
tmux
|
|
neofetch
|
|
nix-zsh-completions
|
|
zsh-completions
|
|
lm_sensors
|
|
wireguard
|
|
wireguard-tools
|
|
nmap
|
|
iperf3
|
|
go_1_12
|
|
smartmontools
|
|
python37Packages.glances
|
|
];
|
|
|
|
programs = {
|
|
zsh = {
|
|
enable = true;
|
|
autosuggestions.enable = true;
|
|
enableCompletion = true;
|
|
ohMyZsh.enable = true;
|
|
};
|
|
};
|
|
}
|