44 lines
1.2 KiB
Nix
44 lines
1.2 KiB
Nix
# Edit this configuration file to define what should be installed on
|
||
# your system. Help is available in the configuration.nix(5) man page
|
||
# and in the NixOS manual (accessible by running ‘nixos-help’).
|
||
|
||
{ config, pkgs, ... }:
|
||
|
||
{
|
||
imports =
|
||
[ # Include the results of the hardware scan.
|
||
./hardware-configuration.nix
|
||
./packages.nix
|
||
./networking.nix
|
||
./services.nix
|
||
./users.nix
|
||
./nix-containers.nix
|
||
];
|
||
|
||
boot = {
|
||
loader = {
|
||
# Use the systemd-boot EFI boot loader.
|
||
systemd-boot.enable = true;
|
||
efi.canTouchEfiVariables = true;
|
||
};
|
||
|
||
extraModulePackages = [ config.boot.kernelPackages.wireguard ];
|
||
};
|
||
|
||
# Select internationalisation properties.
|
||
i18n = {
|
||
consoleFont = "Lat2-Terminus16";
|
||
consoleKeyMap = "uk";
|
||
defaultLocale = "en_GB.UTF-8";
|
||
};
|
||
|
||
# Set your time zone.
|
||
time.timeZone = "Europe/London";
|
||
|
||
# This value determines the NixOS release with which your system is to be
|
||
# compatible, in order to avoid breaking some software such as database
|
||
# servers. You should change this only after NixOS release notes say you
|
||
# should.
|
||
system.stateVersion = "19.09"; # Did you read the comment?
|
||
}
|