nixos-server-config/packages.nix
Michael 0af68cd830 updated 20.09 server configuration
Signed-off-by: Michael <michael.lindman@gmail.com>
2021-10-07 01:05:02 +01:00

36 lines
502 B
Nix

{ config, pkgs, ... }:
{
environment.systemPackages = with pkgs; [
exa
wget
htop
git
(import ./vim.nix)
neovim
nix-index
python2
python3
usbutils
pciutils
tmux
neofetch
nix-zsh-completions
zsh-completions
lm_sensors
nmap
iperf3
smartmontools
btrfs-progs
];
programs = {
zsh = {
enable = true;
autosuggestions.enable = true;
enableCompletion = true;
ohMyZsh.enable = true;
};
};
}