40 lines
1.1 KiB
Nix
40 lines
1.1 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
{
|
||
imports =
|
||
[ (modulesPath + "/profiles/qemu-guest.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = [ "ahci" "xhci_pci" "virtio_pci" "sd_mod" "sr_mod" ];
|
||
boot.initrd.kernelModules = [ ];
|
||
boot.kernelModules = [ "kvm-intel" ];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
fileSystems."/" =
|
||
{ device = "/dev/disk/by-uuid/e578fb8d-c975-4ee8-9f3e-ca2b5a8ef98c";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
fileSystems."/boot" =
|
||
{ device = "/dev/disk/by-uuid/9CF7-499F";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
fileSystems."/home" =
|
||
{ device = "/dev/disk/by-uuid/82220da3-bc20-4ee4-9fc6-a7c47482fc94";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
fileSystems."/mnt/storage" =
|
||
{ device = "/dev/disk/by-uuid/42a9220c-0857-45a3-98a9-7bcfff31d95c";
|
||
fsType = "btrfs";
|
||
options = [ "subvol=storage" ];
|
||
};
|
||
|
||
swapDevices = [ ];
|
||
|
||
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
|
||
} |